cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

Quick Patch problem

Hi,

It seems that I misunderstood something regarding Quick Patch for an installation.

I had an original installation for some of my clients, lets call it version 1.0.0

Then I created a series of Quick Patches, v1.0.0.1, v1.0.0.2, v1.0.0.3

Everything was Ok till now...

As I have some new clients without v1.0 installed, I decided to create a new install, version 1.0.0.3 which will include all the Quick Patches in the initial install. So I did it, and now when I try to Quick Patch the initial installation, the v1.0.0 I get an error saying:
The upgrade patch cannot be installed ... because the program to be upgraded may be missing or the upgrade patch may update a different version of the program...

I have verified, the Product code installed (HKEY_CLASSES_ROOT\Installer\Product\ is the same as in the Update.exe.

In the InstallShield.log at the end I get error 1642.

What did I do wrong? What is the correct procedure for such case ie how can I incorporate the QuickPatch in the installation so that the new QP will work with both installations (quick patched or newly installed)?

And what should I do now to correct the problem?

Thanks in advance for any help.

Igor

0 Kudos
4 Replies
Highlighted
Flexera beginner

Re: Quick Patch problem

Forgot to mention, I'm using InstallShield Express version 2016, version 23 SP2.
0 Kudos
Highlighted
Flexera beginner

Re: Quick Patch problem

Hello I am also facing same problem .

Can anyone suggest how to reslove the issue.

0 Kudos
Highlighted
Moderator Moderator
Moderator

Re: Quick Patch problem

Can you try the steps in this KB article and see if it resolves the issue

https://community.flexera.com/t5/InstallShield-Knowledge-Base/Error-code-1642/ta-p/4028

0 Kudos
Highlighted
Flexera beginner

Re: Quick Patch problem

Hi ,

I read the article.I am using a patch design view under this it is mention below.

You will now need to add an additional item in the Previous Setups section. As an example there is a product with a base version of 1.0. This product has two patches that install versions 1.1 and 1.2 of your product. The first patch configurations latest version entry points to version 1.1 of the product and the previous version entry points to 1.0 of the product. The second patch configurations latest version entry pointed to version 1.2 of the product and the previous version entry points to 1.0 of the product. In this setup the second configuration will not work if version 1.1 is installed on the machine. To make this second configuration work against 1.1 an entry is needed in the Previous Setups section for version 1.1

what does the last line says.?

To make this second configuration work against 1.1 an entry is needed in the Previous Setups section for version 1.1

What entry is to be done ?

0 Kudos