Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 6

Problem with web installer after InstallShield upgrade

Today I upgraded my BasicMSI project to InstallShield 2012 (from IS2011) and run into an issue with web installer.

Fresh install fails with error
“Error 1606.Could not access network location /TRAYF~~1.CAB”
(where is correct path).

Here is msi log just before the error :
“Download of URL resource /TRAYF~~1.CAB failed with last error 2”

There is no such file as TRAYF~~1.CAB in the , but there is TRAY.F~1.CAB.

The cab in question is first .cab for custom Merge Module. On machines where custom merge module is already installed by some other our product the issue with upgraded installer does not occur.

I tried to use both merdge modules – build by InstallShield 2011 before upgrade and by InstallShield 2012 after it – result is the same.

Release type is Web – Install From The Web – One .cab per component.
The only change to the project was made by InstallShield upgrade. Before it everything worked fine.

What should I do to fix the issue?
Labels (1)
0 Kudos
(4) Replies
Level 6

Hi again

I finally found the workaround – do not put “.”(dot) in first 6 characters of component name if you want to use web installer with one cab per component.

The issue appears not only with merge modules (where I first found it) and not only after project upgrade. Just for fun (yes, I’m that boring) I checked next scenario:
1)Create new basic MSI project with InstallShield2012
2)Add one file to the installation and name its component “test.mytheory”.
3)Add release with parameters Web – Install From The Web – One .cab per component.
4)Build the release, put files in expected online location and run the setup - > will get “Error 1606.Could not access network location < web_location>/TESTM~~1.CAB”. Which is true as, in fact, cab is named “”
5) With component name “mytheory.test” web installer works correctly.

Is this new InstallShield limitation?
0 Kudos
Level 6

And one more – merge module component names should contain more than 6 characters (to not run into name.msm_guid component name with undesired dot)
0 Kudos
Level 2

We're having the same problem, except that we're using the Visual C++ 9.0 CRT (x86) WinSXS MSM merge modules, which means InstallShield creates cab files with a dot in the first 6 characters that we have no control over. There's no "just don't do it" option for us.

Has anybody tried pursuing this with Flexera? It definitely reeks of bug.
0 Kudos
Level 4

I'm experiencing this as well with InstallShield 2013 SP1. My company is named FARO, so many of our assemblies have the name format Faro.XXXXXX.dll. The build process seems to be mangling the cab file names in the Media table. For instance, the file Faro.DeviceControlPanel.Modules.FaroArmSerial.dll resides in the file, but the Media table references FAROD~~1.CAB in the Cabinet column.

Hopefully Flexera will see this post, because this has to be a bug.
0 Kudos