cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kriz_82
Level 5

Problem with Standalone build on x64 bit platform

Hello,

I installed Standalone build 2010 on the windows 2008 x64. WHen i tried to run msbuild task I got following error message:

error MSB4062: The "InstallShield.Tasks.InstallShield" task could not be loaded from the assembly C:\Program Files (x86)\MSBuild\InstallShield\2010\InstallShield.Tasks.dll. Could not load file or assembly 'file:///C:\Program Files (x86)\MSBuild\InstallShield\2010\InstallShield.Tasks.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format. Confirm that the declaration is correct, and that the assembly and all its dependencies are available.

Bold part indicates that there is a platform mismatch. So my question is:

Simlar problem on the MSBuild forum
http://social.msdn.microsoft.com/Forums/en-US/msbuild/thread/08c1b976-e741-4ea3-91f6-1ae0958f1667

Indeed, if I use x86 version of msbuild then standalone builder will work, but i do not want to do that.

Is there a x64 version of Standalone builder? and if not, how can i workaround this issue?


Any help would be appreciated.

Regards!
Labels (1)
0 Kudos
4 Replies
MichaelU
Level 12 Flexeran
Level 12 Flexeran

We do not have support for 64-bit MSBuild engines at this time. I've logged a request to add this support (IOA-000058549), but I cannot offer any timelines as to when this might be implemented.
0 Kudos
kriz_82
Level 5

Ok, thank you for the fast response.

Regards!
0 Kudos
Sverre
Level 2

Hi,

Is there any news on this issue?
Are there still no workarounds so we can compile a 64-bit version of our application and still be able to generate our msi automatically?

Best regards,
Sverre
0 Kudos
ravindraguptag
Level 2

Hi all,
I am getting almost similar error while using flexnet giving sample application flexNetActivation.
Error is like this:
initialization failed: an attempt was made to load a program with an incorrect format
(Exception from HRESULT: 0x8007000B)

not able to debug further in this.
please reply.

Thanks in advance
0 Kudos