Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Problem While doing Version Up

I am preparing installer for my application using Install Shield 2011 Premier Edition. I am using BasicMSI option. Till now I released three version 1.0, 1.1, 1.2

Version1.0 is base version and rest are update versions.

On customer request, I removed one folder which contains DLLs and I delivered it as Version1.3. I asked them to uninstall the previous version and install Version1.3 as fresh install.

Now I am going to release update Version1.4. In this I am adding the Folder and its DLLs which i deleted in Version1.3.

When i tried to update Version1.4 over Version1.3, none of the files gets updated. I generated log file while installing and i am not able to see any error message. Also in Log file, there is no information of copying the files to destination folder.

Even in installation progress bar, I am not seeing the message "Updating Component Registration" and "Copying Files".

When I tried to uninstall my application, all files remains in the folder.

I tried creating new Installer also. But it didn't work.

Can some one guide me where I am going wrong, as I am new to Install Shield.

Thanks in advance,
Hari Krishnan.EL
Labels (1)
0 Kudos
(1) Reply
Level 6


Why don't you check the following KB?

Q200372: HOWTO: Troubleshooting Minor Upgrades

It looks like component rules are broken.
0 Kudos