austin2359
Pilgrim

Prerequisite won't install : "won't download" but I don't want to download

Below are my settings.

What could possibly cause it to return the error:
error wrote:
The files for installation requirement 32-lync could not be found. The installation will now stop. This is probably due to a failed, or canceled download.

I'm telling it to extract. Didn't even specify a url to download from.
Labels (1)
0 Kudos
7 Replies
DebbieL
Pilgrim

Re: Prerequisite won't install : "won't download" but I don't want to download

Check to see what is selected in the InstallShield Prerequisites Location setting on the Setup.exe tab for your release in the Releases view. This setting lets you override all the of the prerequistes' locations that are configured in the Redistributables view. You may want to select Follow Individual Selections for the InstallShield Prerequisites Location setting. The help that is displayed in the lower-right pane when you select this setting has more information.
0 Kudos
austin2359
Pilgrim

Re: Prerequisite won't install : "won't download" but I don't want to download

DebbieL wrote:
Check to see what is selected in the InstallShield Prerequisites Location setting on the Setup.exe tab for your release in the Releases view. This setting lets you override all the of the prerequistes' locations that are configured in the Redistributables view. You may want to select Follow Individual Selections for the InstallShield Prerequisites Location setting. The help that is displayed in the lower-right pane when you select this setting has more information.

It worked. Setting it to ignore reboot commands also has helped, if other people are reading this thread and addressing similar issues.

There is an option which allows you to make the requirement optional. It throws you a message box which resembles "The program optionally uses this requirement. Would you like to install it now?"

Can I change the contents to say something else? Like "This program is required. Only cancel if you already have it installed."
0 Kudos
DebbieL
Pilgrim

Re: Prerequisite won't install : "won't download" but I don't want to download

The strings on the setup prerequisite dialog are not editable from within InstallShield, but you can edit them in the InstallShield Program Files Folder\Support\0x****.ini files before building the release. The English strings are in the 0x0409.ini file. The particular string you are asking about is 1669.

I hope that helps.
0 Kudos
austin2359
Pilgrim

Re: Prerequisite won't install : "won't download" but I don't want to download

DebbieL wrote:
The strings on the setup prerequisite dialog are not editable from within InstallShield, but you can edit them in the InstallShield Program Files Folder\Support\0x****.ini files before building the release. The English strings are in the 0x0409.ini file. The particular string you are asking about is 1669.

I hope that helps.


Thank you. I think this will work.
0 Kudos
austin2359
Pilgrim

Re: Prerequisite won't install : "won't download" but I don't want to download

DebbieL wrote:
The strings on the setup prerequisite dialog are not editable from within InstallShield, but you can edit them in the InstallShield Program Files Folder\Support\0x****.ini files before building the release. The English strings are in the 0x0409.ini file. The particular string you are asking about is 1669.

I hope that helps.


By any chance, can the cut off limit be increased to hold more text in these built in dialogues?
0 Kudos
DebbieL
Pilgrim

Re: Prerequisite won't install : "won't download" but I don't want to download

Um, well, can we back up just a moment? I have a question about this:
Can I change the contents to say something else? Like "This program is required. Only cancel if you already have it installed."


Are you sure that an end user will know whether the program is already installed? It seems the more you present end users with questions like that, the more chances there are for things to go wrong. Also, if you've set up the conditions for your prerequisite correctly, the installation would not try to install the prerequisite, and the installation would not display a "My Product optionally uses My Prerequisite. Would you like to install it now?" message box. Thus, you would never run into a scenario where an end user would be prompted to install the prerequisite when it's already installed. If a prerequisite is not optional, it shouldn't be marked as optional. Is it possible that the conditions for your prerequisite are not set up correctly, and the installation is sometimes prompting end users to install the prerequisite even if it is already installed?

About this:
By any chance, can the cut off limit be increased to hold more text in these built in dialogues?

Which dialog string are you describing? If you are referring to the optional message box, it should resize as needed. Can you post a screen shot that shows the dialog string?
0 Kudos
austin2359
Pilgrim

Re: Prerequisite won't install : "won't download" but I don't want to download

We changed our strategy.

On an install, there will be no messagebox if the user already has it. The prereq will just be skipped.

If the user does not have it, however, they have the option of saying no. This is done in case the user has a newer version of the product. IE they have version 5.x, you don't want to force them to install version 4.x. So they get an option. But they no longer get an option if they already have the same version.

The message box was getting truncated, but we simply shortened the message.
0 Kudos