kalleh
Level 3

Prereq reboot

Hi!

I have written a prerequisite and have used the option "Reboot the machine and resume on reboot". I have two problems to which I have not found any solution (even if I have searched these forums)

1. The most troublesome is that the machine reboots but the installation is not resumed! Why? Any ideas? I think it works fine on XP SP3 but not Win7, but I am not sure.

2. Is it possible to suppress the reboot prompt for the user and just reboot?

Thanks in advance!
Labels (1)
0 Kudos
3 Replies
kalleh
Level 3

Hi again!
I have found out what the problem is but not yet found any solution.

The prq requires admin priviliges to run and hence if, I after the reboot, log in as Admin the setup is resumed. However, if I log in as normal user the setup does not resume.

I imagine I am not the only one with this problem. Do anyone knows of a solution so the installation resumes when the user log in after setup?

(I noticed the RunOnce key under HKCU in the registry when looking at the register as Admin.)

Thanks
0 Kudos
MichaelU
Flexera
Flexera

Are you doing an "over the shoulder" style elevation - i.e. are you providing a separate administrative user account (instead of elevating to the administrative version of the same account)? If so, I'll see if we can reproduce this case in house to get started on a fix.
0 Kudos
kalleh
Level 3

Hi!

"Are you doing an "over the shoulder" style elevation" - i.e. are you providing a separate administrative user account" - Yes, this is what I am doing.

I also noted the following behaviour. If I for on the prereq Behavior tab check:

- Exit and resume on reboot: The installation stops. I reboot manually, log in as user and the setup resumes.

- Prompt the user only if no reboot is detected, but always reboot the
machine and resume on reboot: The PC reboots (without prompt), I log in as user and the setup resumes.

- Prompt the user to reboot the machine even if nothing is detected, and
resume on reboot: Prompt is given. Yes, The PC reboots I log in as user and the setup resumes. No: I reboot manually, log in as user and the setup resumes.

- Reboot the machine and resume on reboot: Prompt is given. Yes, The PC reboots I log in as user and the setup DOES NOT RESUMES. No: I reboot manually, log in as user and the setup resumes.

So the last option does not seem to work as I expected. I have chosen to use the second last alternative for now as it works ok.

Thanks!
0 Kudos