[Incident]: Some users report they are unable to access the case portal. Please see this community notice for more information.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
tarmo_pikaro
Level 3

Packaging 64-bit activex component...

Hi !

I have problem with making 64-bit auto-installable active-x component using installshield - and I would like to get in touch with your support on this matter.

I've managed to successfully make both - 32bit installation .exe for activex (using Intel as architecture in "template summary", packaging into one .exe file as well as for 64bit (using x64 in same place) - can be installed without a problem.

Both installs works fine (when executed from explorer), I have double/triple checked all instalation pathes, activex self-registration, 32/64 bit components.

However - when placing installation on web page - I can detect what internet explorer end-user is using and provide corresponding code base according to processor architecture:





Code snipet borrowed somewhere from internet.

Installation from web works fine for 86x architecture but not for x64 architecture.

I have noticed also that re-creating package with .cab all-in-one file makes things working again - but .exe still does not work.

I have tried different kind of tricks / configurations in internet explorer but without any result (reducing security and so on).

I have used file monitor / process monitor and find out that during execution internet explorer writes one temporary file where it's mentioned following:


*** Code Download Log entry (02 Feb 2012 @ 19:57:38) ***
Code Download Error: (hr = 800700d8) Incompatible Binary for your platform
Operation failed. Detailed Information:
CodeBase: file:///C:/Projects/activextest/Lohja2001_activex7/setup/setup.exe
CLSID: {2C6D93E0-B7D1-4A72-B7C4-5E2CD26DE180}
Extension:
Type:

LOG: Reporting Code Download Completion: (hr:800700d8 (FAILED), CLASSID: 2c6d93e0..., szCODE:(file:///C:/Projects/activextest/Lohja2001_activex7/setup/setup.exe), MainType:(null), MainExt:(null))
--- Detailed Error Log Follows ---
LOG: Download OnStopBinding called (hrStatus = 0 / hrResponseHdr = 0).
LOG: URL Download Complete: hrStatus:0, hrOSB:800700d8, hrResponseHdr:0, URL:(file:///C:/Projects/activextest/Lohja2001_activex7/setup/setup.exe)
LOG: Reporting Code Download Completion: (hr:800700d8 (FAILED), CLASSID: 2c6d93e0..., szCODE:(file:///C:/Projects/activextest/Lohja2001_activex7/setup/setup.exe), MainType:(null), MainExt:(null))





Searching forums and internet also did not gave me any meninfgul results (I have also tested with two different copies of windows 7 / 64 bit).

I however suspect that windows installer 64-bit does not work like 32-bit - but don't know reasons why - nothing is mentioned anywhere.

I have noticed also that x64 does not produce 64 bit installation package - it's still seen in task manager as 32-bit application, which however is capable of updating 64-bit applications.
(Don't know how you achieve it) - but don't believe this is the root cause of problem.

May be you have a clue what goes worng or direct contacts - to Microsoft installer for example ?
Labels (1)
0 Kudos
5 Replies
MarkusLatz
Level 8

when I read your code snippet I see that you check for x64 architecture. But on a 64-Bit OS you have also the 32-Bit version of IE and the 64-Bit version of the IE. You must also check in which IE version your code is called. Because the 32-Bit IE version can only register 32-Bit ActiveX components even if it is a 64-Bit OS. Hope this solves your problem.

regards

Markus
0 Kudos
tarmo_pikaro
Level 3

Yes, I know about this -
by default x64 computer has IE's of x64 and 86x, and you can launch both IE's , and they will care only about correspondent activex architecture - e.g. x64 IE cannot load 86x activex and vice versa - 86x IE cannot load x64 activex.

In similar way you need to select correct installation package, as I'm doing it in javascript.

May be we could chat about this e.g. in Skype ?
0 Kudos
MarkusLatz
Level 8

I have no skype. But read your private messages ....
0 Kudos
tarmo_pikaro
Level 3

Raised as a problem to Flexera installshield - case

http://support.flexerasoftware.com/case/View.aspx?id=004000000000CCA9

and they rejected whole idea, meaning Flexera InstallShield officially does not support ActiveX 64-bit installation.

I by myself made such support via .cab file for first time installation, after that my own component takes care of updating.

Just if anyone is intrested:

http://download.vianova.fi/vm/demo/

(Bug reports directly to me over mail)
0 Kudos
tarmo_pikaro
Level 3

Raised as a problem to Flexera installshield - case

http://support.flexerasoftware.com/case/View.aspx?id=004000000000CCA9

and they rejected whole idea, meaning Flexera InstallShield officially does not support ActiveX 64-bit installation.

I by myself made such support via .cab file for first time installation, after that my own component takes care of updating.

Just if anyone is intrested:

http://download.vianova.fi/vm/demo/

(Bug reports directly to me over mail)
0 Kudos