flotek72
Pilgrim

.NET Framework 4.5.1 requiring a restart when set as prerequisite.

I'm using a Basic MSI installer and created my own .NET 4.5.1 prerequisite. When this prerequisite runs and installs, it says it requires a reboot. If I install the prerequisite by itself without involving InstallShield, it does not require a reboot.

.NET Framework 4.0 prerequisite does not seem to require a reboot when triggered from the InstallShield installer.

My prerequisites for 4.0 and 4.5.1 both have command line parameters of /q /norestart.

What would be causing this in the prerequisite bootstrapper? Also, why does it have this problem with .NET 4.5.1 and not .NET 4.0?
Labels (1)
0 Kudos
2 Replies
jgkenned
Pilgrim

I am having the exact same problem. My prerequisite is for .NET 4.5 web. It is a basic MSI project with a setup launcher. I am getting a forced reboot which I did not get for earlier versions of my product that used .net 3.5 and 4.0. When I install only .net 4.5 on a clean machine it does not require a reboot. I would like to "safely" eliminate the call for a reboot.

thanks
0 Kudos
jgkenned
Pilgrim

I ended up upgrading to IS 2015 and I see the same issue. There should not be a reboot required for .net 4.5 installation. If I can install .net 4.5 by itself without a reboot requirement, then why would it be any different with a setup installer?
0 Kudos