cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
skr
Level 6

.NET 3.5 problem

I have posted an InstallShild 2009 problem earlier bu got not response. Is there a mailaddress whereto I can post problems??

Mu problem is;

I do have an installation that requires .NET 3.5.

On my target machine I have .NET3.5 SP1 installed. When I try to install my application (it requires .NET 3.5) on this machine my istallation fails stating that it requires "Microsoft .NET Framework needs to be installed for this installation to continue"
Labels (1)
0 Kudos
1 Reply
racoon82nz
Level 4

You need to modify the install condition from Product Properties. You probably have something like:

DOTNETVERSION35="3.5.21022.08"

What you need to do is change the '=' sign to '>=':

DOTNETVERSION35>="3.5.21022.08"

By doing so, if SP1 exists on the target machine, the install will continue as the SP1 version is >= than the non SP1 version.

Hope that helps.
0 Kudos