Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

My WPF app exe is created, but doesn't do anything when running.

My install shield project says it's completed everything ok in the log, some warnings, no errors.
When I run the exe it creates, it says it installs it and launches it. But when it runs, i don't see it anywhere and it looks like a background process or something. All the DLLs seem to be in there.
I created a very simple WPF with telerik controls and when I compiled and ran that with the same settings it worked ok.
Now I did notice differences in the install folder
I have this in my solution folder
and under here I only have setup.exe

Now, on the one that worked, I have a lot more files including an MSI:

I have a DVD-5 vs this singleImage. I also have an MSI and other files?
What did I do wrong?

This is the last part of my log file:

Resolving strings...
Language English (United States) built
Building .cab files... built
Files built
Media table successfully built
Setup.exe created
Automatic update notification disabled
Express\SingleImage - 0 error(s), 13 warning(s)
Labels (1)
0 Kudos
(2) Replies
Level 3

Ok, I changed the configuration to a DVD-5 and it makes everything, but it still doesn't do anything when I run it. There no user interface window that pops up.
How can I debug what it's doing? I didn't see anything my computer's events log
0 Kudos
Level 3

Now I'm seeing an error message in my events:

Application: MyApp.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileLoadException
at MyApp.App..ctor()
at MyApp.App.Main()

then a 2nd error:
Faulting application name: MyApp.exe, version:, time stamp: 0x52fe9f0f
Faulting module name: KERNELBASE.dll, version: 6.3.9600.16496, time stamp: 0x52b3e015
Exception code: 0xe0434352
Fault offset: 0x00012eec
Faulting process id: 0x8dc
Faulting application start time: 0x01cf29d9ac7b2fb6
Faulting application path: C:\......\MyApp.exe
Faulting module path: C:\WINDOWS\SYSTEM32\KERNELBASE.dll
Report Id: ea3472a4-95cc-11e3-be8c-d43d7ebf3818
Faulting package full name:
Faulting package-relative application ID:
0 Kudos