Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

MsiExex.exe has Application error after installed SP2

I've working on the InstallScript MSI project.
That project is working successfully with previous SP1. For Install/Uninstall.
But after applied SP2 to my IS2016 Premier, the generated installer has happened Application error.

I cannot do it on Sp2 again to checking and solving this problem.
because I was backing restore to Sp1 now.

It looks happened on final step after installation doing.
All files are installed OK on INSTALLDIR and the installed application is working also OK.

The problem is the Application Error dialog appeared only.

Can you check and solving this problem?

Thank you,
Windows Event Log is below.

Faulting application name: MsiExec.exe, version: 5.0.14393.0, time stamp: 0x57899002
Faulting module name: ucrtbase.dll, version: 10.0.14393.0, time stamp: 0x57898db2
Exception code: 0xc0000005
Fault offset: 0x000531ce
Faulting process id: 0x6ec
Faulting application start time: 0x01d2d2a4a2c0aca8
Faulting application path: C:\Windows\syswow64\MsiExec.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report Id: 0b9ad4d9-ea43-46b4-a152-ba8ce493c02d
Faulting package full name:
Faulting package-relative application ID:
Labels (1)
0 Kudos
(4) Replies
Level 9

Most of us on this forum are just other users - I have seen a couple of Flexera employees on here but it is not very often and they don't get into troubleshooting any issues here.

If you have a support contract with Flexera - what I do is contact them using my support agreement and let them know about the problem directly. This way they can open a case and assign that to the engineers. That's been about the only way I've seen that they will pick up an issue and make a change. This forum doesn't seem to cover that possibility.

0 Kudos
Level 3

Hi Chad,

Thank you for your reply.

Yes, I think I have a contract of support of this product.
My contract is Silver Maintenance.
But I did not use the support before. because it post is not easy and I don't like spend so much my time.

I will be waiting next fix released. And I will try again that release before using my main road job.
I know that release of InstallShield has problem every time, I could not use 2016 version before applying SP1 also.

I'd like to say thank you to your reply, anyway I can work with previous SP1, that has working OK now.

Thank you so much.
0 Kudos
Level 13

If you have a Silver support contract it would still be a good idea to submit a ticket. If you don't, Flexera may not be aware of the problem and it won't be fixed in the next release either!
0 Kudos
Level 3

Hello rguggisberg,

Thank you, but I already rollback the SP2 environment and I cannot replay this problem when a support guy is needed.
And my license is node locked, I cannot prepare also the test environment to solved this issue.
If I will try post it to a support, I guess I cannot give some good enough information.

I will check next release and I hope it solved on that release. If not I will post the ticket at that time.

Thanks again,
0 Kudos