gilberttt
Pilgrim

Latest Setup will not uncompress

I'm using IS 2011 pro.
When building a patch I go and select my latest install. It is a self extracting exe. I get the dialog that says:

"The selected setup is compressed. Patch creation requires that the setup be uncompressed. Would you like InstallShield to create an uncompressed version of this setup now?"

I select YES, select a folder for InstallShield to decompress my install, choose ok and get a dialog that states:

"The dialog specified is invalid"

What does that mean? It decompressed my previous install just fine as it was an MSI. Am I not able to easily patch a compressed EXE? Do I have to install it somewhere, go get the cached MSI, copy it to a temp location and use that to create my patch?:confused:

Any help would be appreciated!
Labels (1)
0 Kudos
1 Reply
Cary_R
Pilgrim

Re: Latest Setup will not uncompress

Hi There,

To decompress it, it basically invokes the setup with:

setup.exe /a /v"/qb+"

To do an administrative install. This is required so that the microsoft Patch API's can do direct comparisons against the uncompressed files. It's actually a requirement of those API's and less for InstallShield, but I digress.

I would start by generating an MSI logfile of the above command like so:

setup.exe /a /v"/qb+ /l*v c:\admin.log"

And see what it says is the matter. I can't guess why it gives an error about a missing dialog, unless there's several issues, like an error occurring, and you've deleted or renamed ErrorDialog.
0 Kudos