cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
td10751
Level 3

IsSABld.exe does not include objects or merge modules

Hi,

I'm just going from InstallShield X to Installshield 2008. I work with the IDE on my PC and want to use the build machine to put together the setups in the night. With the IDE everything looks ok.

Problems occur without the IDE, running the Stand-Alone build with IsSABld.exe

Projects which produce an object can be processed without problems (same files, same palce, same structure as before)
Projects, which contain no objects or merge modules can be processed without problems

Projects, which include either Merge Modules, own objects or objects delivered by Macrovision do compile. That means the ism-file is found, the setup.rul is compiled and a setup.inx appears

Then it stops without any indication of an error. The Log Files folder contains a file "error" without extension and a lenght of 0 byte.

This is the command line:
"C:\Programme\Macrovision\IS 2008 StandaloneBuild\IsSABld.exe" -p "y:\ISAR_install\Installshield\Tracer\Tracer.ism" -r "Default" -o "C:\Programme\Macrovision\IS2008\ObjectsPro\Microsoft .NET Framework Object"

I have tested several path values with the "-o" option and there is no change at all.

Reading through the forums, I found that a similar problem occured with IS 11.5, but it should have been fixed in IS12. But I have IS2008 resp IS14.

Can anybody help me please?

Sincerly
Thomas
Labels (1)
0 Kudos
4 Replies
esiemiat
Level 9

Did you install the objects on the StandAlone build machine? You can use the same installers that you used to install the objects on your development machines. For your custom objects you will either have to install the objects manually, or create an installer for them yourself using the InstallScript Object Installer Object.

If the objects are installed perhaps the bug described in the following thread is the culprit.

http://community.installshield.com/showthread.php?t=170605
0 Kudos
td10751
Level 3

Hello,

thank you very much for the trial.

It is definitely not the bug described in the link. I copied the issetup.dll to the windir and winsysdir, but it does not change at all. Anyway in my IDE there is no such file in either windir or winsysdir.

Then I made a small new object, and a small project which includes the object. Same result. The projects are new, not taken over from Installshield X.

I have installed everything I could (because some setups require the IDE), anyway I only need MFC and .Net. With the merge module for MFC I have some progress. The setup is created, but everytime during creation the setup of VS2005 pops up, works for about 10 minutes and dissapears again.
With the IDE the merge module is created within seconds an no other setup pops up. There is still something very wrong.

Now I will continue with the .Net object and I still hope for a good idea

Thanks
Thomas
0 Kudos
esiemiat
Level 9

The solution in the link does not say to copy the file into the WinDir or WinSysDir, but into the system folder under the TARGETDIR for the Standalone Build install.
0 Kudos
td10751
Level 3

Thank you Eric,

that is exactly the solution.

I will have to figure the thing with the merge module and the .Net, but I will first read a little bit.

Thanks
Thomas
0 Kudos