- Revenera Community
- :
- InstallShield
- :
- InstallShield Forum
- :
- Installshield Activation Wizard has stopped working
- Mark Topic as New
- Mark Topic as Read
- Float this Topic for Current User
- Subscribe
- Mute
- Printer Friendly Page
Installshield Activation Wizard has stopped working
I had these problems today:
I wanted to share my fixes since it was difficult to find the answer and support was not helpful (didn't respond back).
Problem:
The product license has been corrupted. You must repair the license before you can continue. Click yes to repair now.
After I click Yes, I get this message: “Installshield Activation Wizard has stopped working”
Solution:
SOLUTION
• Un-install, reinstall Installshield 2018 (might not be needed. Try deleting the MVSN_* files first before uninstalling - next step)
• Navigate to %ProgramData%\Flexnet (might be %ProgramData%\Flexera in other versions)
• Show all hidden files and Delete all files starting with MVSN_*
• Open InstallShield 2018 and it should now work
Cause:
The cause of this appeared when IT changed out MAC Address on a build machine with a Perpetual Install (IDE/Development).
Other Solutions:
Let IT/DevOps know that build machines with Node-Locking Installshield licenses need to have a static MAC Address. The license is tied to the HostId (MAC Address). This is an issue we ran across with a SAB (Stand alone build) install also. Since you can only return a license once a year, a static MAC Address makes sense.
SAB Change MAC Issue:
PROBLEM
The product license has expired or has not yet been initialized.
SOLUTION
The HostID (MAC Address) has most likely changed on that machine. Check the Flexera Licensing site and the MAC Address on that machine. IT can either change the MAC Address back, or your have to return that license and issue a new one for that address/machine.