cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
petewalburn
Pilgrim

Installing .Net 4.0 Framework during install

Hi,

I have Installshield 2010 Express and have an Install project in Visual Studio 2010. I would like to install the .Net 4.0 Framework during the install (if it is not already installed).

I can include the Framework as a prerequisite, but only have .Net 2.0, .Net 1.1 and .Net 1.0 in the Releases section of Installshield. In fact, in the Redistributable section, if I selecy Microsoft .Net Framework 4.0 Client, I am prompted:
"The Redistributable you have selected is either not installed on this computer, or there is a newer version available from Acresso. Would you like to download the redisributable now?"

I press the Yes button, and receive the message: "The download failed. Would you like to try again?". I can try any number of times, but it never downloads.

Am I doing something wrong?

My application uses .Net Framework 4.0 and so I need this to be installed on the target machine if it is not there. How can I do this?

Pete
Labels (1)
0 Kudos
2 Replies
DebbieL
Pilgrim

Re: Installing .Net 4.0 Framework during install

If you are using Windows Vista or later, you may be running into a problem stemming from not having administrative privileges. The problem and the resolution are described in the following help topic:
Launching InstallShield with vs. Without Administrative Privileges

I hope that helps.
0 Kudos
petewalburn
Pilgrim

Launching As Administrator

Thanks for that - I followed the instructions to launch as administrator and it worked fine.
0 Kudos