Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

InstallShield failed to extract COM data for an .ocx file

I have a product that uses an old COM component which is an .ocx file. It was fine when I used InstallShield 2010 Express to build the product release.

Early this year, I upgraded to InstallShield 2021 R1 and recently we need to release the product to our users. The InstallShield 2021 R1 successfully converted the old .ise file to .ism file and have the release successfully built. However, our product installation test shows the COM server of the old component is not registered. We eventually found that the InstallShield 2021 R1 is unable to extract the COM data from the .ocx file. I've also tried the RegSpyUI of the InstallShield 2021 R1 and also unable to extract the COM data. The RegSpyUI of the InstallShield 2010 has no problem extracting the COM data.

I have just downloaded and installed the latest InstallShield 2022 R1 and do the same COM data extraction and it cannot extract COM data from the .ocx file also.

I have attach one of the .ocx to help demonstrate the issue.

I wonder if anyone face similar issue and has any resolution. Any help is much appreciated.


Labels (2)
0 Kudos
(4) Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi - 

I've tried to duplicate this - but I'm not able to.

-Created a new Basic MSI project
-In component settings changed "COM Extract at Build" to YES
-Added olch2xu8.ocx as the Key file to the component

Clicked Build

No build errors and build log showed COM data extracted correctly


I opened the built MSI using Installshields Direct Edit view and was able to see that it had correctly included the extracted registry data from the .ocx file


I also tried in RegSpyUI and everything appeared to work as expected.


Are you following these same steps?

0 Kudos
Level 3

Hi shunt,

Thank you for the quick response.

I do the same steps as you did, and the result screens follows:



As you can see in above image, there is build warning indicates failure of COM data extraction.



The direct edit of the MSI created shows no COM data has been added to destination registry.



The RegSpyUI image also shows no COM data extracted.

Is there any settings in InstallShield that would affect the COM data extraction?

Is there anything you can suggest me to try?

Thanks and regards,


0 Kudos
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi @sychan,

Thank you for your post.

We'll need a support ticket (case) to track this issue. Could you please open a case with our Support Team, about this issue, by email at or by phone at (877) 279-2853, as long as you have an active, valid, unexpired technical support contract (maintenance plan)?

Please let us know if you have any questions or concerns. Thanks!

0 Kudos

Thanks Ian,

I have emailed a request to the email Help the issue will be addressed soon.

Thanks and regards,


0 Kudos