Revenera Documentation site will be unavailable on July 2nd due to scheduled maintenance. For more information see the status dashboard.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jaredfx
Level 4

InstallShield Redistributables

How do I download/install redistributable packages on our build machine, if Visual Studio is not installed? TFS 2010 RTM
0 Kudos
13 Replies
Lenwin
Level 10

I understand that you have not installed Visual studio 2010.ISLE can be used only by integrating it with Visual studio 2010.Could you let us know if you are trying to download the redistributable package through ISLE or as a separate download??
0 Kudos
jaredfx
Level 4

I'm trying to find a separate download. I downloaded the packages on my development machine through the InstallShield LE Redistributables screen inside VS 2010, and that worked great. My issue now is that when I build inside TFS 2010, the installation builds but is missing the redistributable packages (because they haven't been downloaded/installed on the TFS build machine).
0 Kudos
Marwan
Level 7

The easiest way is to simply copy the content of the SetupPrerequisites folder found under the InstallShield folder from your dev machine to the same location found on your TFS build agent machine.
0 Kudos
jaredfx
Level 4

I am still getting the following warnings:

ISEXP : warning -6245: One or more of the project's components contain .NET properties that require the .NET Framework. It is recommended that the release include the .NET Framework.
C:\Program Files (x86)\MSBuild\InstallShield\2010Limited\InstallShield.targets : warning : -6245: One or more of the project's components contain .NET properties that require the .NET Framework. It is recommended that the release include the .NET Framework.

I expected these warnings to go away after copying the SetupPrerequisites folder from my development machine to the build machine. The output installation does not contain the .NET Framework redistributable (almost as if InstallShield LE didn't recognize the files I copied). Any ideas?

Thanks!
0 Kudos
Lenwin
Level 10

Hi,

The -6245 Build Warning message can be resolved if the “C:\Program Files\InstallShield\2010LE\SetupPrerequisites” folder on the build machine contains the same .prq file that has been selected in the InstallShield Limited Edition .isl project file under the redistributables view.

Could you let us know if you have selected the prerequisite in the InstallShield Limited Edition project file using the IDE, copied the updated .isl project file to the build machine and the same prerequisite .prq file is present on the build machine in the same location as on the Visual Studio development machine.

If you are still encountering the same issue then kindly send us the .isl project file that was copied to the build machine so that we can investigate further.

Thanks,
Lenwin
0 Kudos
jaredfx
Level 4

The Microsoft .NET Framework 4.0 Client.prq file is listed below. I'm wondering how the folder gets resolved. We have various versions of the InstallShield product installed on the build machine. I'm not sure that this tag is picking up the correct location for the file. I've also attached the .isl file in case it might be helpful to you. Thanks for your help.




















<ISProductFolder>\SetupPrerequisites\Microsoft .net\4.0\x86\Client\dotNetFx40_Client_x86_x64.exe" URL="http://download.microsoft.com/download/5/6/2/562A10F9-C9F4-4313-A044-9C94E0A8FAC8/dotNetFx40_Client_x86_x64.exe" CheckSum="1CF262F35322D6C9C7A27FCA513FC269" FileSize="0,43000680">








0 Kudos
Lenwin
Level 10

Hi,

Thank you for getting back to us with the project file.

From the project file we see that “Microsoft .NET Framework 4.0 Client” has not been added to the InstallShield Limited Edition project.

To add the prerequisite to the project, kindly perform the following steps:

1) Using the Visual Studio IDE, open the InstallShield project.
2) In the Solution Explorer, expand #2 “Specify Application Data”.
3) Double click on “Redistributables” to open the Redistributables view
4) Scroll down the list of redistributables and mark the check box labeled “Microsoft .NET Framework 4.0 Client”
5) Build the project and verify the -6245 build warning does not occur
6) Copy this modified .isl project file to the build machine.

Thanks,
Lenwin
0 Kudos
jaredfx
Level 4

Sorry for the delay. I've been extremely busy on other projects. As for adding “Microsoft .NET Framework 4.0 Client” to the installation, I did add it with similar results on the build machine. This is what I ended up doing to get everything working:

I installed Visual Studio Professional on the build machine. I then uninstalled InstallShield LE (because Visual Studio could not determine that it was installed). Then, I installed InstallShield LE and activated it (activation code - which I had no way to activate it before...no user interface, until VS 2010 was installed). I then had to download the redistributable from inside the InstallShield LE / Visual Studio interface (even though the "SetupPrerequisites" folder had been copied from my development machine...where the redistributable had been previously downloaded). Now everything is working fine. It would be very helpful to be able to activate/setup InstallShield LE on a build machine without having to install Visual Studio.

Thanks for the quick responses and all the help that was offered!
0 Kudos
Lenwin
Level 10

Hi,

We are glad that everything is working as expected.

InstallShield Limited Edition comes integrated with Visual Studio 2010.

We do have standalone editions of InstallShield which are independent of the Visual Studio Software.

InstallShield Premier and Professional are the standalone editions available. The Premier and Professional editions have additional features which are currently not available (“locked”) in InstallShield Limited Edition.

Thanks,
Lenwin
0 Kudos
jaredfx
Level 4

So, is the expectation for those using TFS 2010 to install VS 2010 and InstallShield LE on the same machine where the TFS build controller resides?
0 Kudos
Lenwin
Level 10

Hi,

Yes. As InstallShield Limited Edition is integrated with Visual Studio 2010 it is mandatory to have Visual Studio 2010 installed if you wish to use InstallShield Limited Edition.

Thanks,
Lenwin
0 Kudos
denny
Level 3

Lenwin wrote:
Hi,

Thank you for getting back to us with the project file.

From the project file we see that “Microsoft .NET Framework 4.0 Client” has not been added to the InstallShield Limited Edition project.

To add the prerequisite to the project, kindly perform the following steps:

1) Using the Visual Studio IDE, open the InstallShield project.
2) In the Solution Explorer, expand #2 “Specify Application Data”.
3) Double click on “Redistributables” to open the Redistributables view
4) Scroll down the list of redistributables and mark the check box labeled “Microsoft .NET Framework 4.0 Client”
5) Build the project and verify the -6245 build warning does not occur
6) Copy this modified .isl project file to the build machine.

Thanks,
Lenwin


QUick Comments:

1) I wish this would have been pointed out in the video or in the install builder, too a while to find this.

2) downloading the files needs ADMIN rights? WHAT? why can't i just download the files w/o having to close VS and re-start as an admin?
0 Kudos
Lenwin
Level 10

Hi Denny,

Kindly refer the following link. It has a brief description regarding the minimum requirements for systems to run the InstallShield Software.

http://www.flexerasoftware.com/products/installshield/requirements.htm

Thanks,
Lenwin
0 Kudos