Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

InstallShield 6109 - Internal Build Error

Currently we are using InstallShield 2015 for creating Installers for deploying Web Application developed in .NET. We were able to create Installers successfully till couple of months back without any issues.

But after a specific check-in, the InstallShield throws “6109 – Internal Build Error”, which does not provide much clue.

When further analyzed, following are the changes done in that specific check-in.
1. 6 images were deleted and 1 new image and 1 css file were added
2. Controllers and Resource files were modified

Tried to revoke these changes but still the error exists. I created a new IS project and still the error occurs. Error occurs when the content output is included but is successfully build just with primary output.

Have come across few posts that discuss that it could be because of some missing files but in the Project Solution there were not any missing files or from the dependency scan done in the Installshield.

Can anyone who has experience similar issue can suggest on how to figure out missing files in the Installshield that could possibly throw the build error?
Labels (1)
0 Kudos
(2) Replies
Level 17

Have you checked out this KB article?
0 Kudos
Level 3

After trying all the suggested fixes in KB article (reinstalling InstallShield LE, checking for missing files specified in application files, files with commas in name, repairing VS 2013 (on which I was getting Error -6109 on build for my project) I eventually found I could select all the Application Files from the Program Assistant Application Files screen, right-click and then set Scan at Build to None. This allowed the build to proceed without error. A project which had previously built OK also failed - haven't tried resetting the Scan at build values for it yet, so I don't know what change caused InstallShield LE to start throwing the error.

Repairing VS 2013 (running on Win 10) was problematic - needed to turn off Malwarebytes malware protection to avoid a hang and then got prompted for some missing msi files which I was able to download. I had uninstalled .Net 4.5 which crippled Visual Studio and downloading and trying to install .Net4.5.1 failed as it said it was already installed (Win 10 uses .Net 4.6.2). Fortunately the repair of VS2013 reinstalled .Net 4.5.1 but Netver executable still says its not installed. .Net 4.5.1 appears now in Programs and Features list.

Postscript: after changing Scan at Build to None, all files required have to be manually added in the Application Files Window. If any aren't present the installer may complete successfully on a target machine but then crash on execution, sometimes with only a crashdump file to indicate what was wrong. I can't find any application which performs the scanning function to detect dependencies and thus needed files and I've had to work from the files packaged before InstallShield LE manifested this bug.
0 Kudos