cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

InstallShield 2019 component not overwriting with newer files

I have a problem with a specific minor upgrade installation that refuses to overwrite newer files. The files have a newer version, (17.0.0.197 to 17.0.1.263) and the installation uses the same product and upgrade codes. Tested with different package codes and with the same and nothing. 

I am completely stuck. I have checked the ISM file through SVN history and found no changes since my previous minor upgrade that would prevent me from installing. The only thing different is that I don't use a couple of prerequisites that have nothing to do with the files I am changing.

Labels (1)
0 Kudos
1 Reply
Highlighted
Flexera beginner

Re: InstallShield 2019 component not overwriting with newer files

I have NO idea why, but I tried something crazy and it worked. 
I went to MEDIA -> Upgrades -> Upgrade Windows Installer Setup -> Common  and changed the settings for Minor Upgrades and Major Upgrades to something else. I build and it worked. Files where copied and overwrote older versions. Changed back the settings to the ones I wanted, build again and it worked. Now the files are being copied and overwrite old files!

This seems to be some kind of crazy corruption, but I don't know what. 

I have the R3 version of InstallShield 2o19, but this was also true for R1

0 Kudos