cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Flexera beginner

InstallShield 2015 - can not activate after Hyper-V machine moved to another server

Hello!

We have a purchased single perpetual license to InstallShield 2015 Proffesional (currently updated to SP1).

It works on an Hyper-V virtual machine, to secure our investment from emergencies like virus infections or hardware faults. The VM is isolated from internet and most of our LAN, we want the data streams to be maximally controlled, what we ship to our clients should have no unpredictabilities.

This year we started migrating our process from the old ailing installation-building server to a new dedicated one. We shut down the IS 2015 Hyper-V machine on the old server, moved it to the new server, and run it there. All seemed going nice. We moved the old server to old hardware depot and were working with new server and the IS2015 VM on it.

Until recently, when IS 2015 started some 20 days "countdown". It was a shock, because it was documented with have a "perpetual" license, we never thought our "perpetual" purchase may stop working on a whim of some external actor, due to politicians fall-outs or something. At no moment in time there was two computers running with Install Shield, when we moved the VM to another server it even retained the same IP address, it would be just impossible to run two VMs without noticing it. Perpetual purchase should work perpetually, shouldn't it?

We searched through this forum and the forum suggests we have to "return" the license on the VM before move and re-aquire that very same license after the move.

We rushed to recover the old server from the depot, happily it still was operational and was not cannibalized yet. We shut down the IS2015 VM on the new server and re-launched that VM that was ketp on the old server.  We managed to run IS2015 IDE and to "return" license in offline mode, using uploading XML files to WWW form, from that old server. Okay?

We again downed the old server and fired the VM on the new server. We tried both options to "Reactivate" and to "Aquire New License" - it was spawning License.request file, we uploaded it to the form, we had activation.xml generated and copied it back into VM...

....but InstallShield never asked for that file. When after generating "Request.license" file we pressed NEXT button - it kept saying "Activation OK" and quit. But when we tried to launch IDE - it still requested reactivation.

Running TSClient from command line we managed to "Return" the license from the VM on the new server. However when we launch IS2015 IDE we are still asked to re-activate or to add new license or to configure for local license server (which we do not have, we have a single machine perpetual license instead). It remembers our activation code, it spawns xml file with request, but then it never asks for activation response file and falsely claims activation was succesful. Except that it was not and IDE does not even start.

What should we do to make IDE run activated on the new VM server in the same VM it was working for years?

There was some topic with error like "Activations quantity exceeded" that suggests prugng Windows registry, but we never had that error, and purging registry "because we are desperate to do anything" does not seem safe approach.

------------

Additionally, we try to solidify our software purchases from personal e-mail addresses to a dedicated functional role e-mail, this Flexera account is registered using personal e-mail of a person who resigned few years ago. Keepign this e-mail afloat is a mess. How can we transfer this account, both for forum needs and activation needs, to another e-mail on the same server/domain ?

0 Kudos