cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
angel126
Level 4

Install prerequisite during update

Hi all,

we have a product which is delivered to our customer. With the new version of this product, our developer has changed the software so that we have a new prerequisite (Visual C++ 2005 SP1) for it.

Now I have the following problem:
When I include the prerequisite to install before feature selection, the prerequisite is not installed during an update.

When I include the prerequisite to install with a feature, I have the problem that on computer where an older version of sp1 is installed the prerequisite failed, because of the parameter /i. 😞
To integrate two prerequisites with different parameters is not possible, because I have no conditions to differentiate between installation and update, because the entries in the registry are different and I don't know all published versions of Visual C++ 2005 SP1.

Do you have an idea what I can do to solve the problem?
Labels (1)
0 Kudos
1 Reply
enanrum
Level 9

What do you mean Prerequisite? I believe all you need to do is add the redistributable Visual C++ 8.0 Merge Module.

Now, you could have a problem with the Version of the redist, I have IS 2010 and the version of my redist is 8.0.50727.762. I needed the '8.0.50727.4053', I forgot how I got it installed, but I had the developer to send me the vc++.exe or vc++ msm and overwrote the one in IS's location.
0 Kudos