Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4


Hi all,

I've just wrapped up converting our Developer 8-based install to IS 2011, and, after working past a couple of surprises (adding files to components through automation results in all lowercase names??), I've run into an issue that I'm not sure how to get around.

In short, on ISWiComponent I call ImportRegFile, importing data out of a registry file that looks like this:

Windows Registry Editor Version 5.00


On import, the resultant registry table entry would look like this:


and the final result in the registry looks something like this:

C:\Program Files\OurCompanyName\OurProduct\Common\

i.e. I have bracketed variables there that I expect to go verbatim into the registry table -- this worked under Dev8 forever.

However, IS 2011 insists on escaping the characters when importing, resulting in registry table entries that look like this:


and registry entries that look like this:


Obviously this is undesirable -- anyone have any ideas on how to get around this???

Labels (1)
0 Kudos
(3) Replies
Level 17

I attached the InstallShield 2011 hotfix for this issue to this post. In order to apply the fix, you need to copy the new IsMsiEntity.dll to the C:\Program Files\InstallShield\2011\System folder for the IDE, and C:\Program Files\InstallShield\2011 SAB\System folder for the Standalone Build. We have filed the work order #IOA-000058174 so that the fix will be incorporated into future releases of InstallShield.

0 Kudos
Level 4

Thanks for the hotfix! I won't be able to deploy this (I have to wait for the first service pack, to ease distribution on each of our build machines), but I do appreciate your rapid response!

Thanks again!
0 Kudos
Level 3

Holy Cow! Talk about great timing!

I ran into this exact same problem today and was about to post the same issue.

I'm happy to report that the new dll fixes the issue.

Thanks for reporting and also for posting the fix.

0 Kudos