cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Intrepid explorer

ISDEV : error : -4340: Internal build error

There are quite a few posts on the internet for this subject and varying fixes... but none seem to be conclusive. Recently we started getting more "ISDEV : error : -4340: Internal build error"s.

My environment is VS 2013 and InstallShield 2015 SP1 and I build from VS. I have 2 different builds; 1 with 1 InstallScript MSI project and the other with 3 InstallScript MSI projects. Either build may fail and the one may fail on any 1,2,or 3 of the IS projects. I always 'Clean' and 'Build'. Seems like once I get the error I have to restart VS to build successfully. Also seems like it may be worse if I try to do other things on that machine during the build... but not sure about that. Has anyone solved this problem?
Thanks

1/07/2016
We seem to have made this better by adding more memory and making the memory allocation static. This runs on a VM that now has 24 GB of RAM. Still happens sometimes though.

5/6/2016
I'll take that back! It comes and goes. Today I am getting way more failed builds than good builds 😞
Labels (1)
0 Kudos
3 Replies
Highlighted
Intrepid explorer

Solved!

We struggled with this for a long time before I finally gathered enough details to file a support ticket on this one. Thanks to the persistence of George on the Flexera Support team and to the Flexera Dev team this has been resolved with a hotfix for IS 2015. It will also be fixed in IS 2016 SP1. In the past I got many -4340 errors and often had a tough time getting a good build. Since applying the hotfix a couple weeks ago we have not had a single -4340 error 🙂
0 Kudos
Highlighted
Pilgrim

-4340 Internal build error

rguggisberg wrote:
We struggled with this for a long time before I finally gathered enough details to file a support ticket on this one. Thanks to the persistence of George on the Flexera Support team and to the Flexera Dev team this has been resolved with a hotfix for IS 2015. It will also be fixed in IS 2016 SP1. In the past I got many -4340 errors and often had a tough time getting a good build. Since applying the hotfix a couple weeks ago we have not had a single -4340 error 🙂


I am having the same problem with IS2014 Professional. Is there a fix for this problem for the IS2014 version?
0 Kudos
Highlighted
Intrepid explorer

Re: ISDEV : error : -4340: Internal build error

suhass wrote:
I am having the same problem with IS2014 Professional. Is there a fix for this problem for the IS2014 version?


I do not believe so. Flexera provided a hotfix for me (an updated ISUtil.dll) for IS 2015 SP1. That was too late to get into IS 2016, but it is in IS 2016 SP1. If you can't upgrade you may contact Flexera Support about making the change for IS 2014. Might be easier to upgrade.

Hope that helps.

BTW.. With that fix -4340 errors are a thing of the past! Haven't had one since 🙂
0 Kudos