cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Gwynbleid
Level 3

ISCmdBld leaves "Evaluation" message in setup.exe

Hello,

I have faced with the following problem. Our company purchased InstallShield 2008, and I successfully installed it and activated (meaning that it doesn't ask me to register on start-up now and About box shows my serial key). Now when I build my project (converted from IS 12) from within IDE (F7), I receive correct setup.exe output.
But, if I use ISCmdBld.exe to build the same project from the command-line, it displays "Built with EVALUATION version of IS" message when I run setup.exe. And those 2 files setup.exe are even different in size.

Is it a bug of IS 2008? I have never saw this in IS 12 -.
Thanks for a quick feedback.
Labels (1)
0 Kudos
10 Replies
cedric42
Level 3

Same problem for me....

It started with the same error an my computer an nowit display an error when I run the command line build

ISDEV : fatal error -7159: The product license has expired or has not yet been initialized. You must launch the IDE to configure the product license in order to proceed.
0 Kudos
Gwynbleid
Level 3

Well, actually I don't have error during the build from the command line. I just see the "EVALUATION" message box just after I run setup.exe. Then the installation goes as expected, but where this message box comes from in licensed version???

Small update: I have tried creating a new project in IS 2008. I didn't add anything, just tried to build it both ways. And result is the same, so the problem has nothing to do with the conversion from IS 12.

P.S. (not on the topic) I have requested a login ID to IS support, but have been waiting for 2 hours + for the "additional logon information" which was promised to be mailed me... :mad:
0 Kudos
cedric42
Level 3

On my computer it started with the same "evaluation copy" problem.

But since a fiew hours it display this error message...

The next step is probably to burn my CPU 😉
0 Kudos
MichaelU
Level 12 Flexeran
Level 12 Flexeran

This is a known problem, but there's an easy workaround to be documented in a KB soon. Follow these steps to resolve the IsCmdBld process producing an evaluation build from a licensed install:

1) Close down any date-sensitive applications such as Outlook
2) Set your computer's clock forward one month
3) Run your IsCmdBld proccess
4) Set your clock back

You only need to follow them once; future builds should not require changing the date. Alternately you can wait a few weeks and the problem should resolve itself.
0 Kudos
cedric42
Level 3

Nice one thanks for your help...

For the next version please remove this f... activation with is only a problem for registred users but never stoped any pirat to copy your software...
0 Kudos
Gwynbleid
Level 3

Super!!!
Thanks a lot, Michael, and RESPECT!!!
Though the workaround seems like a spell for uninitiated 😉
0 Kudos
Christopher_Pai
Level 16

Heehehe, I actually like this `feature`.

It lets me know when a developer skipped around build automation ( ISSABLD ) and tried to sneek something out the door that was built on his own machine.

Bad developer, bad developer...... 😉
0 Kudos
andrew_iv
Level 3

Hi all,

I have licensed copy of InstallShield Premier Edition 2008 and I'm calling IsCmdBld.exe too. I have two applications doing that equivalent calls: one is win app, second is web app written in ASP.NET. When I run win app everything is fine, but when I run web app - I got message:

ISDEV : fatal error -7159: The product license has expired or has not yet been initialized. You must launch the IDE to configure the product license in order to proceed.

I've found windows FLEXnet Licensing Service, it runs under Local System account.
So I assume that a problem is an account which starts IsCmdBld.exe: with my win app IsCmdBld.exe (and FLEXnet Licensing Service) is running under local account, with my web app it's running under ASP.NET account and FLEXnet Licensing Service is never called.

I would like to ask MichaelU what is possible solution for my issue, I need to run IsCmdBld.exe from web application.
0 Kudos
quantum
Level 2

hi Michael
i use this information step by step and try again but i cann't use iscmdbld.exe and my problem not resolved 😞
can you help me.
0 Kudos
DebbieL
Level 17

Please see if the hotfix provided in KB article Q113513 resolves the issue.

Debbie Landers
Acresso Software
0 Kudos