Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

INI File delete leaves ***IS_STRING_NOT_DEFINED***

:mad: I am going nuts. When using IS2008 Exp working with INI additions and deletions is very ropey indeed. I have tried renaming the offending reference strings and some delete just fine but some reappear without reason.

I am only deleting because importing INI gets strange results and provide duplicates. Also each INI generates an empty INI of the same name without prompting. Saving and Closing has resolved it previously but now I am stuck with this stupid error even if I delete all INI files.

I read that this was a problem but have seen nothing about it in the current known problems. Anyone else got this. Looks like I'll have to rebuild the setup from scratch. Help anyone? Thx:confused:
Labels (1)
0 Kudos
(5) Replies
Level 3

I did a bit more checking and it seems that the INI file problem comes if you have make of several INI files and/or if you import existing INI files and/or if you drag and drop entries between files and/or you copy and paste entries between INI files. I my case I am using four files. We also use the registry but INI file are handy for localized user settings where we don't want users accesing the Registry variables for localized jobs with application macros. When rebuilding the setup I found when I came to the INI four empty entries named "IniFile1" "IniFile2" etc., appeared after I saved and reloaded. I'm guessing if I delete these entries now I will get the IS STRING error. So I won;t be doing it again!

What this seems to suggest is that the INI section code is less than satisfactory at handling all INI configurations and the "fix" provided may need to be stress tested a bit more.

Hope someone from Macrovision is listening. Either way this may be of help to someone.:confused:
0 Kudos
Level 17

Thank you for reporting this. I've been able to reproduce the problems that you described. In InstallShield 2008 Express Edition, one .ini file-related change was fixed, as described in the release notes:
When you add a section to an .ini file and add a keyword to that section in the INI File Changes view, InstallShield no longer displays an IS_STRING_NOT_DEFINED.ini error if you delete the .ini file section.

However, there are still other related problems, as you mentioned. Therefore, I've reopened issue IOA-000030285 and expanded it to include the issues that you described.

Debbie Landers
Macrovision Corporation
0 Kudos
Level 2

I have successfully been using an InstallShield 12 Express project using a manually entered INI File. I now need to import two whole INI files, and have the symptoms reported above. I tried installing InstallShield 2008 Express in hopes that it would solve the problem, but it also does not work. Was there a version of InstallShield Express for which this did work properly, and, if so, is it possible to change the version of the project so that it will work with a prior version? This is killing me. I have already wasted a dozen hours fighting this.

Another problem I have noticed:

Importing an INI file from a directory below the project does not work. For example, a directory called "FOO" that has the project, and a subdirectory within FOO called "BAR", and an INI file called BAZ.INI within BAR, importing BAZ.INI does not work.
0 Kudos
Level 2

I just got this error today. maybe I can add something that will help.

In my case I imported an ini file then deleted all the keywords but the few I had to have set. Then I get this error. After a bit of investigating with Orca, I found that the deleted entries are still there, but the FileName property is set to ***IS_STRING_NOT_DEFINED***.

What I did to get around it is to delete the entries using Orca. In table IniFile you will see the problem entries. Just delete these.

It worked for me anyway.
0 Kudos
Level 6 Flexeran
Level 6 Flexeran

We have a fix for this. Unfortunatley the DLL is too big for the community server. We are workling on getting a KB created for it.

If you need this sooner, please email me at:
0 Kudos