sbeamish
Level 3

IIS and App Pool settings issue

I have 3 separate installer projects that are creating a web application in IIS.

Project1 is the root site and creates the root site and application pool.
Project2 is an application under Project 1 and shares the same application pool.
Project3 is an application under Project 1 and also shares the same application pool.

I'm updating all 3 installers to .NET 4 with the AppPool settings and now Im 0x80070020 Errors (Cannot Access File, File sharing issue) when running the installers on the target machine. My suspicion is that each installer is trying to modify the root site or AppPool settings since this is shared component between all 3 installers.

When running the installers every project is failing with the same error inconsistently and randomly. Project1-2 will work 3 will fail. Run them again and 1,3 will work and 2 will fail, run them again and all 3 will work.

No log file is created since InstallShield rolls back the updates. I have been trying to track down the file access violation using ProcessMonitor to no avail.

So what is the correct way to setup each projects IIS settings so they are not colliding with each other at run time?
Labels (1)
0 Kudos
1 Reply
sbeamish
Level 3

Here is what I have learned over the course of a day to get a little closer.

Installer1 Sets up the Site 0, and AppPool settings
Installer2 is an Application inside Site 0 and uses the same AppPool
Installer3 is an Application inside Site 0 and uses the same AppPool

They install in ascending order and I uninstall in descending order.

In InstallShield Web Explorer - Installer2 and Installer3 I mirror the exact same AppPool and Site Settings as Installer1.

The problem arises when you set the .NET Framework Version = v4.0 in the AppPool in any of the Installer Projects.

I have tried setting it in Installer1 and leaving it blank for 2-3 = FAIL
I have left Installer1-2 blank and set it in Installer3 = FAIL

Hopefully this makes sense. Basically I have one Site deployed with 2 Applications underneath it using 3 Installers and the problem comes from setting the .NET Framework Version to v4.0 in the AppPool.

Im trying to avoid using appcmd.exe in each installer to set the .NET Framework Version in the AppPool in each Installer.

Any suggestions? Hints as to the behavior of InstallShield?
0 Kudos