cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
hank_zhan
Pilgrim

How to let Installshied multiplatform 11.5 use jdk 1.6

Any one can help?

Thanks.
Labels (1)
0 Kudos
6 Replies
RobertDickau
Pilgrim

Re: How to let Installshied multiplatform 11.5 use jdk 1.6

If you're asking about an installer created with ISMP, the documentation describes how to create a .jvm JVM search instructions file and also how to create a new bundled JVM...
0 Kudos
enanrum
Pilgrim

Re: How to let Installshied multiplatform 11.5 use jdk 1.6

You have to bundle it yourself! if you have the 11.5 MP Guide you can check out the instructions there. In Short, do a search on Info-ZIP and install that utility. I'm assuming you have the 1.6 JVM installed on your PC, so cd to the jre1.6... directory. You need to include a jvm search file into the archive, I've attached the one that I use: NOTE - you need to remove the .txt extension, rename to 'jvm'. I could not upload it unless I gave it a recognizable extension. This step seems to be missing from the 11.5MP Guide!

So in the directory: C:\Program Files\Java\jre1.6.0_03 - you have
bin\
lib\
COPYRIGHT
jvm --> the newly created search file
etc..

run the zip command:
> zip -rv9 win32_1.6.zip *

Append the appropriate stub executable to the zip file. This file is installed with Info-Zip - do a search for it: unzipsfx.exe

> copy /b unzipsfx.exe+win32_1.6.zip windows1.6

Adjust the offsets of the bundled JVM installer binary using the -A option to zip:

> zip -A windows1.6exe.exe

Regards,
Tom
0 Kudos
hank_zhan
Pilgrim

Re: How to let Installshied multiplatform 11.5 use jdk 1.6

Very detail.

Thanks a lot.
0 Kudos
babupeddi
Pilgrim

Install Shield11.5 Windows not working on 64 bit platform with jre 1.6

Hi,

Im using Install Shield 11.5 Premier edition.


Jre will be packaged with our Product. So users need not have java installed on their machines. We use the jre packaged with the product to invoke java classes by passing in few arguments.
This will be done in LaunchAppAndWait() method of Install script.
For ex:
C:\Program Files\Thomson\Novus\Java\jre\bin\java.exe -Djava.ext.dirs="C:\Program Files (x86)\Thomson\Novus\lib\novus"; com.westgroup.novus.oem.install.OemInstall OEM_HOME C:\Program Files
In the above command OemInstall class is invoked with 2 arguments. And the java used here is the packaged one. We put the entire command in LaunchAppAndWait method to execute through cmd.exe.
These types of commands are working fine with Windows 2003 32 bit and 64 bit and Windows 2008 64 bit. But when packaged with Jre 1.5 version.
We are planning to upgrade to java 1.6. So now packaged jre will be 1.6 version.
But with jre 1.6 above commands are not working.
Javaw.exe application error window pops up and says it’s not able to reference the memory location specified.
Windows event logs gives out the error with the below message
javaw.exe application error
Faulting module path: C:\Windows\SysWOW64\ntdll.dll
But I tried on different 64 bit machines of 2008 and 2003 to cross verify if there is any problem with the machine that I’m installing. Same error is coming.

Attached is the screen shot
0 Kudos
enanrum
Pilgrim

Re: How to let Installshied multiplatform 11.5 use jdk 1.6

I believe you are running an InstallScript - you should post in Windows installers.
0 Kudos
babupeddi
Pilgrim

Re: How to let Installshied multiplatform 11.5 use jdk 1.6

Yes I posted there also...... But no reply... Any help is appreciated
0 Kudos