cancel
Showing results for 
Search instead for 
Did you mean: 
ZygoCorp
Flexera beginner

Help setting destination directory!!

THIS IS AN INSTALLSCRIPT PROJECT.

I want to set the destination for several of my components to:
FOLDER_COMMON_APPDATA \ IFX_COMPANY_NAME \ IFX_PRODUCT_NAME \ namex

However in the IDE, I cannot set the Destination folder to \\\namex to have the 3 strings evaluated.

I could hardwire the company name and product name if I had to, but would prefer not to for maintenance reasons. What I want is the 3 defined variables evaluated appropriately (FOLDERS_COMMON_APPDATA is evaluated differently based on the OS) to create a new base directory for me to palce files into.

I wanted to make a "user-defined variable" PROGRAMDATADIR - something akin to targetdir (of course, when installshield decides to fully support win7 predefines this will conversation probably not be necesssary) that I could use in my code and for destination directories, but I couldn't find any documentaiton on HOW to do it (ex: FeatureSetTarget()). I am setting a registry entry to this path as well so one place, one name would be best.

ASAP help needed!! because of course I neeed this working wedneday morning........
Labels (1)
0 Kudos
2 Replies
bchavez
Pilgrim

Re: Help setting destination directory!!

We are in an identical situation as we update our app to be installed to Windows7. I have been researching this community and studying the help files for some time and am amazed that no one here seem to know how to take care of this problem and/or hasn't run into this situation.

I have just run across this script that may be of help, called SpecialFolders.PRG

http://doughennig.blogspot.com/2007/01/finding-paths-for-special-folders.html

I am not yet sure how to incorporate this script yet, will be looking into that. Posting it here in case others find this useful.

If anyone has another way of working around this problem please post.

Thanks in advance,

BC
0 Kudos
bchavez
Pilgrim

Re: Help setting destination directory!!

Found what I needed here, just needed to know what to search on.

I modified the script example in this post:

http://community.flexerasoftware.com/showthread.php?t=165208&highlight=SHGetPathFromIDList

The writer of this post said these functions did not work, but they worked for me when I altered them to fit my existing structure. Maybe the problem was a bug in the specific version of the product he was using (IS 11.5). At any rate putting this up here for other users as it worked for me.

BC
0 Kudos