cancel
Showing results for 
Search instead for 
Did you mean: 
cada0310
Pilgrim

Fail to create virtual directory on Windows 2008 Server

Hi there,

My installation is failing to create a virtual directory for IIS under Windows 2008 Server (under Default Web Site). The same installation works on Windows Server 2003.

I saw some issues mentioned over on Installshield 2008 forums, but wondered if there was a resolution here. I just installed 2010 SP1, and have the same issue.

Thanks,

Chris
Labels (1)
0 Kudos
8 Replies
cada0310
Pilgrim

Re: Fail to create virtual directory on Windows 2008 Server

A little more data; if I create the virtual directory manually, all the files get installed to where they should be via the installation, so the real issue seems to be with the actual creation of the virtual directory.

Thanks,

Chris
0 Kudos
joshstechnij
Pilgrim

Re: Fail to create virtual directory on Windows 2008 Server

Can you attach a verbose log of the failing installation?
0 Kudos
Highlighted
cada0310
Pilgrim

Re: Fail to create virtual directory on Windows 2008 Server

Hi Josh,

Funny you should mention that...I tried to do that, but nothing seems to be coming out in the log.

I go into the project settings, MSI Log File tab, check everything, and put C:\My_Installation.log in the log file edit box, and nothing comes out.

We do the same thing for another one of our installations with Installshield 11, and it works fine. Is there something else I'm missing to get the log file generated?

Thanks,

Chris
0 Kudos
cada0310
Pilgrim

Re: Fail to create virtual directory on Windows 2008 Server

One more piece of information...for some reason, when it does create the virtual directory properly on Windows 2003, the virtual folder path is set to "[IISROOTFOLDER]NAS", rather than the expanded property like I'd expect.

Thanks,

Chris
0 Kudos
joshstechnij
Pilgrim

Re: Fail to create virtual directory on Windows 2008 Server

The simplest way to create a log would be launching the setup from a command prompt:
setup.exe /v"/l*v C:\PathToLog\LogFile.log"

-- or --
msiexec.exe /I "C:\Path\MsiPackage.msi" /l*v "C:\PathToLog\LogFile.log"

Regarding the installed folder path, this is likely the cause of the failure on IIS 7.x machines (this path is invalid and IIS 7 verifies the path is accessible which will cause a failure). The IIS support resolves this path assuming it is a Directory table entry or property name. To ensure a Directory entry is used for this path, click the ... button on the Content Source Path setting for your virtual directory. This will bring up the Browse for Directory dialog where you can select (or create) a directory entry to be used.
0 Kudos
cada0310
Pilgrim

Re: Fail to create virtual directory on Windows 2008 Server

So here's what I did - I went back and looked at my web site setup in Installshield, and I think I figured out what went wrong.

In the "Content Source Path (Local or UNC)" edit box for my virtual directory, I clicked the down arrow on the far right, picked [IISROOTFOLDER], and then typed my folder name after it in the edit box, so it looked like "[IISROOTFOLDER]NAS". Doing it like this, nothing worked, and the actual string given to IIS was exactly "[IISROOTFOLDER]NAS" - not having the property's value put in there.

When I went back in to check, I used the ellipses [...], browsed to my subfolder, and it inserted "{NAS}[IISROOTFOLDER]NAS" for me, and everything works fine now.

Not exactly obvious...but things are working now.

Thanks for your help, Josh.

Chris
0 Kudos
nhenny2008
Pilgrim

Re: Fail to create virtual directory on Windows 2008 Server

cada0310 wrote:
So here's what I did - I went back and looked at my web site setup in Installshield, and I think I figured out what went wrong.

In the "Content Source Path (Local or UNC)" edit box for my virtual directory, I clicked the down arrow on the far right, picked [IISROOTFOLDER], and then typed my folder name after it in the edit box, so it looked like "[IISROOTFOLDER]NAS". Doing it like this, nothing worked, and the actual string given to IIS was exactly "[IISROOTFOLDER]NAS" - not having the property's value put in there.

When I went back in to check, I used the ellipses [...], browsed to my subfolder, and it inserted "{NAS}[IISROOTFOLDER]NAS" for me, and everything works fine now.

Not exactly obvious...but things are working now.

Thanks for your help, Josh.

Chris


I had to do the same thing, this seems like a bug to me. I didn't change my physical path for the project when I converted from IS2009 to IS2010 and it broke...then I spent a full day of work between yesterday and today to get it to work correctly....I think you guys should make sure the property is recognized and converted.
0 Kudos
joshstechnij
Pilgrim

Re: Fail to create virtual directory on Windows 2008 Server

Migrating a project from IS 2009 to 2010 should not break any IIS related functionality with respect to the physical path of an IIS item. The physical path used by an IIS item is migrated untouched from the RootDir column of the ISIISCommon table in the old project to a new record in the ISIISProperty table in the new project (which has a FriendlyName of 'Path' and the MetaDataValue value containing the old RootDir column value).

IS 2009 provided the same runtime behavior with respect to the physical path used by a website or virtual directory, i.e., it had to be either a Directory table key or a property name without brackets. However, after looking into this, it appears changes made to the IIS view for IS 2010 is the likely cause of this behavior. Specifically, the IIS view in IS 2009 would create a new Directory table entry when a physical path was manually entered for a website or virtual directory. This behavior is no longer occurring in IS 2010. I have submitted work order IOA-000053950 to have this behavior addressed in the future. Using the ellipsis button to browse for or create a new Directory entry can be used to work around this issue.
0 Kudos