cancel
Showing results for 
Search instead for 
Did you mean: 
EKallen
Pilgrim

Error with MDAC on Windows 10 Technical Preview

We just tried installing our product under Windows 10 Technical Preview and are getting an error:

MDAC 2.5 Sp3 cannot be installed on this machine. MDAC 2.5 Sp3 requires any one of the following configurations:

Microsoft Windows 95 with Internet Explorer 3.02 or later
Microsoft Windows 98 with Internet Explorer 3.02 or later
Microsoft NT® 4 with Internet Explorer 3.02 or later
Setup will exit now. Please restart the Setup after installing the necessary updates to this machine.

The install works fine on released versions of Windows including 8/8.1 and MDAC 6.3.9600 seems to be installed on the target machine. We could update the installs to use the MDAC 2.8 merge module (we still need to be able to install on Windows XP). Is this a solution? Does MDAC really need to be installed anymore or is it already automatically installed on Windows?

Thanks,
Ed
Labels (1)
0 Kudos
2 Replies
DLee65
Pilgrim

Re: Error with MDAC on Windows 10 Technical Preview

We no longer include MDAC in our installers. Since XP SP3, MDAC 2.8 has been included with the operating system. As long as your base operating system requirements is XP sp3 or greater then you should be good.
0 Kudos
MarcSayer
Pilgrim

Re: Error with MDAC on Windows 10 Technical Preview

EKallen wrote:
We just tried installing our product under Windows 10 Technical Preview and are getting an error:

MDAC 2.5 Sp3 cannot be installed on this machine. MDAC 2.5 Sp3 requires any one of the following configurations:

Microsoft Windows 95 with Internet Explorer 3.02 or later
Microsoft Windows 98 with Internet Explorer 3.02 or later
Microsoft NT® 4 with Internet Explorer 3.02 or later
Setup will exit now. Please restart the Setup after installing the necessary updates to this machine.

The install works fine on released versions of Windows including 8/8.1 and MDAC 6.3.9600 seems to be installed on the target machine. We could update the installs to use the MDAC 2.8 merge module (we still need to be able to install on Windows XP). Is this a solution? Does MDAC really need to be installed anymore or is it already automatically installed on Windows?

Thanks,
Ed


Ed, I had the same issue with an install of PagePlus X2 on Win 10TP. I found your post here while looking for a solution. I also found a relevant post on the MS Win10 forum, here https://social.technet.microsoft.com/Forums/en-US/7f2b2db4-5059-47d1-a118-83187f23a22f/mdac-required... A solution was offered by one of the members that did eventually work for me. He suggested using orca to edit the msi file to eliminate the call for MDAC 2.5. His specific solution wasn't quite right, as he said to delete an item that I did not happen to have (neither did the OP on that thread). But the general idea to edit out the references to MDAC 2.5 in the msi file was right. I posted my solution and results on that thread. Hope it helps. Oh one other thing, if you do not have orca and do not want to install the entire SDK just to get it, I found a download of just orca here http://blogs.msdn.com/b/astebner/archive/2004/07/12/180792.aspx
0 Kudos