midnite11
Pilgrim

Error ocurred streaming.........into setup.exe Cannot get build completed!!!!

Really need help here.!!!

Installshield Professional 2011 is what I'm using. Installed on a basic windows 7 laptop.
Been using this version for two years now with some frustrations due to random errors being generated during the build process....but just clicking build release again and again seems to finally (sometimes 10 times) finish a setup.exe.
I AM REALLY GETTING FRUSTRATED WITH THIS PRODUCT.

Yesterday I posted and I'm suddenly getting a merge module error. Well, similar to the last two years, clicking build release, or closing IS and then reopening - this seems to disappear.

However, not I'm CONSTANTLY getting this error:

"An error occurred streaming C:\Development\CCERT Install\CCERT\Release 2\DiskImages\Disk1\C-CERT.msi into setup.exe"

Immediately followed by: "Cannot delete file C:\Development\CCERT Install\CCERT\Release 2\DiskImages\Disk1\C-CERT.msi"

And then I'm left with two files: the Setup.exe file which will not work now and the C-CERT.msi file.

This entire folder path has full security rights for any User (made sure of this).
So, I really don't understand what's going on here - suddenly as I'm been using this IS Project on this machine for two years.

Do I need to upgrade to IS 2012 or a later version?

PLEASE HELP!!
Labels (1)
0 Kudos
2 Replies
ch_eng
Flexera beginner

Re: Error ocurred streaming.........into setup.exe Cannot get build completed!!!!

midnite11,

Usually when I get the "Cannot delete file ..." error it is because I accidentally left that folder open. Try closing it or at least backing out to "C:\Development\CCERT Install" and see if that works? That's my only idea.

HTH
0 Kudos
midnite11
Pilgrim

Re: Error ocurred streaming.........into setup.exe Cannot get build completed!!!!

ch_eng - thanx. Tried that did not work....

Did a whole bunch of more googling on this and tried everything I read. Even un-installed are re-installed. Thought about going to Installshield 2014 just to see if maybe this was a bug that was fixed in future releases :(but my packages I need to create are not worth another 3K for a one developer purchase.

Ultimately, what worked, at least for me, was to 100% turn off my Virus Protection. When I did that, the Installshield process finished, every time, without incident.
Installshield is the ONLY software application I have on my computer that will NOT WORK without the Virus Protection turned off. I find that Amazing and very frustrating.
So, moving forward, in order to build my install packages I must first disconnect from the Internet, turn off my Virus Protection and then I can use Installshield.

Sorry, but I find that to be simply ridiculous.......
0 Kudos