cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Directory + where is my property

Hi,

i have a basic msi project who made in installshield 11.5.
It's not me the setup developer but before yesturday i must to compile this project under is 2008
Now, i have upgrade this project to installshield 2008.
All has been done, i have installed yesturday this product and all is perfect !

In this project there is on file and folders :
installdir and under installdir there is a folder name executables and in this directory all file has been added.

in this project i have the possibility to build the product in differents release. that's work.

But since yesturday and i don't know why, when i install this project, this project fails in a custom action who launch a *.exe store in installdir\executables !
Of course the file *.exe is IN the package, this file is not ready only !

It's a function installscript who launch this *.exe.
there is a msiGetproperty for to have the path to the folder executable
and of course the launchappandwait !

i have put some trace for to see if the msigetproperty works, but when i do :


nRetCode = MsiGetProperty(hMSI, "EXECUTABLES", szSrcFile, cchValueBuf);
MessageBox(szSrcFile , INFORMATION);


szSrcFile is still EMPTY !!!!!!I don't understand why yesturday the project worked !!!!!

this property is not on the table PROPERTYMANAGER and there isn't not set property on the custom action !
i think the property comes with the creation of the folder under installdir ! is it possible !?
If i click right on this folder, properties i can see the property EXECUTABLES !

Someone can tell me what happen in this project or give me some idea ?

Thanks for all
Christophe
Labels (1)
0 Kudos
3 Replies
Highlighted
Flexera
Flexera

Re: Directory + where is my property

If you have the name and value of the property set up correctly, the most likely candidate is that your cchValueBuf isn't set to a large enough value. Try making sure it's not zero, and be sure to reset it between multiple MsiGetProperty calls (if you have more than one).
0 Kudos
Highlighted
Pilgrim

Re: Directory + where is my property

ChristopheOce wrote:
Hi,

i have a basic msi project who made in installshield 11.5.
It's not me the setup developer but before yesturday i must to compile this project under is 2008
Now, i have upgrade this project to installshield 2008.
All has been done, i have installed yesturday this product and all is perfect !

In this project there is on file and folders :
installdir and under installdir there is a folder name executables and in this directory all file has been added.

in this project i have the possibility to build the product in differents release. that's work.

But since yesturday and i don't know why, when i install this project, this project fails in a custom action who launch a *.exe store in installdir\executables !
Of course the file *.exe is IN the package, this file is not ready only !

It's a function installscript who launch this *.exe.
there is a msiGetproperty for to have the path to the folder executable
and of course the launchappandwait !

i have put some trace for to see if the msigetproperty works, but when i do :


nRetCode = MsiGetProperty(hMSI, "EXECUTABLES", szSrcFile, cchValueBuf);
MessageBox(szSrcFile , INFORMATION);


szSrcFile is still EMPTY !!!!!!I don't understand why yesturday the project worked !!!!!

this property is not on the table PROPERTYMANAGER and there isn't not set property on the custom action !
i think the property comes with the creation of the folder under installdir ! is it possible !?
If i click right on this folder, properties i can see the property EXECUTABLES !

Someone can tell me what happen in this project or give me some idea ?

Thanks for all
Christophe


Make sure you're using the directory name from the directory table. You can see this quickly by looking at one of your components (the .exe for example) and the property between the {}'s. If you added/removed, this might be incremented and EXECUTABLES might be EXECUTABLES1 or some such.
0 Kudos
Highlighted

Re: Directory + where is my property

Hi both,

thanks for you great help

Cromagnon35 => yes that's right i have an entry EXECUTABLE1 in the directory table !!!!! i have delete, build again my project and run and that's works !

Really thanks for your help
Christophe
0 Kudos