cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

Direct MST issues

I am having an issue modifying an MSI with an MST, actually two issues.

When I create the MST it asks if you want to compress the file into a CAB or save the files uncompressed. No matter which option I use choose when I run the install it cannot locate the files that I am adding to the MSI via the MST. The install fails with a 1603. If I copy the files out of the folder (when using uncompressed) or extract them from the CAB (when using the compressed option) and place them directly in the folder where the MSI resides, the install will work. This is not a normal behavior for Installshield as I have created direct MST's numerous times in the past without this issue. It has only been since upgrading to 2019 that I have come across this.

The second issue is that I want to change the folder permissions on a folder that the MSI creates. I want to add Authenticated Users to have modify rights to that folder. I have done this in the past without issue as well; only since 2019 have I seen this. I can create the permissions on the folder and they show up in Installshield that they have been modified, but when I run the installer, the permissions are not written. I have even tried to modify the permissions directly from the component I added that drops my files.

Any ideas?

Labels (1)
0 Kudos