cancel
Showing results for 
Search instead for 
Did you mean: 

Deployment Problems ***HELP**

So here is the deal:
> I ported a VB 6.0 project to Visual Studios 2013
> Corrected the 100+ errors and prog runs fine
> Installed INSTALLSHIELD limited addition and activated
> Created a setup and deployment file and it installed fine on my IDE PC - prog works in this machine
> But, can not get the setup and deployment to work on onther PC's. It appears to work/install as it goes through the motions; short-cuts install and the program is listed in CONTROL PANEL.
> However, trying to start the program does nothing. I get the circular wait cursor for a few seconds (used to be hour glass) and then nothing.

Any ideas?
0 Kudos
5 Replies
jcoone
Pilgrim

Re: Deployment Problems ***HELP**

Check the Application Event logs, it is possible you are missing a prerequisite for the program to run. Something you have installed on your dev machine but not the target machine.

Odds are the application is crashing on launch due to a missing file or reference.
0 Kudos

Event Log

Yes, there is an error in the Event Log , but it refers to KERNELBASE32.DLL - whis is on the machine. There is no other refernece to any missing file. Is there a way to determine required prerequisites?
0 Kudos
jcoone
Pilgrim

Re: Deployment Problems ***HELP**

Are there any other errors or warnings from the .Net Framework around that same time? those usually come in pairs
0 Kudos

.Net Framework

Yes, there is also a Framework error. Namely: SystemInvalidOperationExcpetion
0 Kudos
jcoone
Pilgrim

Re: Deployment Problems ***HELP**

ok, so your application tried to do something that was not a valid operation. the details of that exception should give you an idea of where to start looking for missing dependencies or frameworks.
0 Kudos