Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Custom action gives me a 1722 error

I have run this custom action with Installshield Limited Edition for Visual Studio in the past and it has worked. But now when I try this with Installshield 2016, this custom action gives me a 1722 error and rolls back the installation. The log file doesn't give any more detail than "failed with error 1..." and the 1722 error.

My custom action setup via the Wizard -

Working Dir: InstallDir

FileName & Command Line: "[SystemFolder]cmd.exe" /c "[INSTALLDIR]somefilename.exe" "'%r' '%keyname=keyname' '%keydll=some.dll' '%appexe=[INSTALLDIR]differentfilename.exe'"

What this is supposed to do is run somefilename.exe from the command line, with parameters "%r", "%keyname", "%keydll" & "%appexe".

When I run it on the command line directly so - "C:\Program Files (x86)"\somefilename.exe "%r" "%keyname=keyname" "%keydll=some.dll" "%appexe=C:\Program Files (x86)\differentfilename.exe" - it runs fine.

I think I am missing some quotes someplace and I have tried various combinations with no luck.

Any ideas what I am doing wrong?

Thanks in advance!
Labels (1)
0 Kudos
1 Reply
Level 2

After trying several combinations of quotes around strings here's what finally worked -

"[SystemFolder]cmd.extension" /c start "" /d"C:\Program Files (x86)\foldername\" "somefile.extension" "%r" "%keyname=something" "%keydll=something.dll" "%appexe=C:\Program Files (x86)\otherfilename.extension"

Hope someone benefits from this.

ps: I cannot put a filename with the extension of an executable on the Forum board as it gets rejected - hence "extension"
0 Kudos