cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Bryan_Thorell
Level 2

Converted from IS 7 to IS 2011

I have converted an install script from IS 7 to IS 2011, all seemed to go perfectly, I have installed on several machines here at the office, and even several clients with no issue.

However, some clients get an "Unhandled Exception" dialog box with an error number: 0x80004005 with a very helpful description of "Unspecified error", and the install terminates.

One client is running a 32-bit 2000 server, and the other is running a 2008 64-bit server, so it doesn't seem to be related to the version of windows they're running.

I'm wondering how I can track this down, if there is some kind of log I can look at, and where that would be.

Thanks,

Bryan Thorell
ManagementPlus
Labels (1)
0 Kudos
7 Replies
Bryan_Thorell
Level 2

So another client running Server 2003 gets the error 0x80040707
DLL function call crashed: ISRT._RegQueryKeyValue, Setup will now terminate.

Is there something I'm missing?
0 Kudos
Reinhold
Level 2

We are in the same situation with our installer. The error happens very sporadically on different machines. It happens only with upgrade installations, not with new installations on newly installed Windows. And it happens on physical machines as well as on virtual VMware ESX clients.
We are in contact with Flexera about this.
Please keep me informed as soon as you know more about this. I will also update you.

Thanks,

D. Reinhold
0 Kudos
joshstechnij
Level 10 Flexeran
Level 10 Flexeran

Can you attach a sample project to this thread that reproduces the behavior you are seeing?
0 Kudos
Trevor_Toth
Level 2

Has there been any update on this thread (i.e. fix and/or workaround)? We are also seeing the sporadic ISRT._RegQueryKeyValue error on upgrades from an InstallShield InstallScript project that was upgraded from v2009 to v2011.

Thanks - Trevor
0 Kudos
busboy
Level 2

I had problems with Unhandled Exception when running InstallShield 2011 in debug mode - it failed consistently every time, even on a simple test project

The computer I was using had a 1920x1080 screen resolution. When I reduced resolution to 1280x1024 the exception disappeared. I do not know why - but it works for me 🙂 Going back to full resolution will make exception reappear so there seems to be a bug in the InstallShield software.
0 Kudos
joshstechnij
Level 10 Flexeran
Level 10 Flexeran

What was the color depth set to when running at 1920x1080? If it is less than 15-bit (32,767 colors), there is currently a known issue with some palette handling code in the engine that causes an exception to occur. Running an InstallScript setup on a machine that has a color depth of at least 15-bit will resolve the behavior (most modern versions of Windows won't even run in 256 colors, but it appears that some machines still get into this state somehow).

This issue will be resolved in a future release of InstallShield.
0 Kudos
busboy
Level 2

Yes - When screen size was 3200x1200, the color quality dropped to Low (8 bit). Changing to 1280x1024 and using color quality Medium (16bit) all is working fine.
0 Kudos