cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Pilgrim

Clean Registry, Install, immediately uninstall - ActiveX still registered

Hi;

I've quite a few posts and didn't immediately see a fix for this problem.

I start with a clean registry and installation directories.

Run my InstallShield MSI.

Immediately Uninstall the application.

The registry still has most of the ActiveX components registered and the files are left in the installation directory. It is a requirement from our customer that these be removed, and frankly, I'm disappointed with the product for not making simple things like this very clear. I won't tell you how long I tried to make a simple readme.txt file pop up at the end of an installation.

Hope someone can help.
Labels (1)
0 Kudos
2 Replies
Highlighted
Pilgrim

Re: Clean Registry, Install, immediately uninstall - ActiveX still registered

To start, how are you registering the ActiveX control? Using COM extraction, or self-registration, or...?
0 Kudos
Highlighted
Pilgrim

Re: Clean Registry, Install, immediately uninstall - ActiveX still registered

I'm not entirely sure - I did VB project scans initially.

This created a series of feature files, which I cleaned up.

There were a series of components created, one for each project (dll, ocx and exe). I cleaned these up also. Initially I was dealing with the "files and folders" view.

I read a thread to clear the key files so I tried that. This didn't resolve the problem.

Then, after more reading, in the component view, I set all the "shared" settings to "no". This didn't resolve the problem.

Then I went to the component view and cleared those key files. This didn't resolve the problem.

Then I set every component to "self register". This seems to have worked.

So, I guess I fixed it?!
0 Kudos