cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
dshapovalov
Pilgrim

Can not create virtual directory if there is custom error page defined

I have a project where a virtual directory is created with custom error page. It installs fine on XP, but fails on Vista or W7. Below is the part of MSI log related to the problem. If I remove custom error page then installation works fine. IISHelper.dll from Q200236 is applied. Also, I tried to add these settings to being installed web.config, so installation would not have to set them, but for some reason installer does not see them and still trying to set the settings. So it fails with these sections in web.config or without them. Please, advise how it can be fixed. Thank you.













1: Changing CommitPath from 'MACHINE/WEBROOT/APPHOST' to the following: MACHINE/WEBROOT/APPHOST/Default Web Site/MLWeb
1: SetVRtDWProperty for property '2104' with value '2'.
1: AppHostElement objects detected. Unsupported property.
1: getvaluelog
1: SetVRtStrProperty for property '6006' with value 'index.htm'.
1: GetAdminSection for section 'system.webServer/defaultDocument' and path 'MACHINE/WEBROOT/APPHOST/Default Web Site/MLWeb' and commitpath 'MACHINE/WEBROOT/APPHOST/Default Web Site/MLWeb'.
1: No element found with property 'value' value of 'index.htm'.
1: PutPropertyValue: sProperty value sValue index.htm bIsPath 0
1: PutPropertyCommon: sProperty value sValue index.htm bIsPath 0
1: getvaluelog
1: getvaluelog
1: Setting property 'value' to value 'index.htm' for element 'add'. Old value: ''. m_sSectionName : 'system.webServer/defaultDocument'.
1: getvaluelog
1: put_value succeeded. get_StringValue now returns '0' with string value 'index.htm'.
1: Adding the following element: add
1: CommitChanges for path 'MACHINE/WEBROOT/APPHOST/Default Web Site/MLWeb' and physical path 'C:\inetpub\wwwroot\MLWeb\'.
1: Changing CommitPath from 'MACHINE/WEBROOT/APPHOST' to the following: MACHINE/WEBROOT/APPHOST/Default Web Site/MLWeb
1: SetVRtDelimMultiszProperty for property '6008' with value '403,4,URL,/MLWeb/jumpSSL.html'.
1: GetAdminSection for section 'system.webServer/httpErrors' and path 'MACHINE/WEBROOT/APPHOST/Default Web Site/MLWeb' and commitpath 'MACHINE/WEBROOT/APPHOST/Default Web Site/MLWeb'.
1: No element found with property 'statusCode' value of '403'.
1: PutPropertyValue: sProperty statusCode sValue 403 bIsPath 0
1: PutPropertyCommon: sProperty statusCode sValue 403 bIsPath 0
1: getvaluelog
1: getvaluelog
1: Setting property 'statusCode' to value '403' for element 'error'. Old value: ''. m_sSectionName : 'system.webServer/httpErrors'.
1: getvaluelog
1: put_value succeeded. get_StringValue now returns '0' with string value '403'.
1: Adding the following element: error
1: AddElement failed with the following HRESULT: '-2147024894':
1: Error with IISRT: -2147024894. Error translation: The system cannot find the path specified.
Action ended 18:32:54: InstallFinalize. Return value 3.
Action 18:32:54: Rollback. Rolling back action:
Labels (1)
0 Kudos
2 Replies
Naveed
Pilgrim

Re: Can not create virtual directory if there is custom error page defined

I am facing similar problem. You got any solutions for yours?
0 Kudos
dshapovalov
Pilgrim

Re: Can not create virtual directory if there is custom error page defined

Yes, upgrade to IS Express 2010, it's fixed there
0 Kudos