cancel
Showing results for 
Search instead for 
Did you mean: 
RatBoyGL
Pilgrim

Can anyone tell me why this installer is "Rolling Back" right after doing the IIS?

So, I have two releases. Lets call them version 1 and version 2.

If I point InstallShield at Version 1's folder, build, and test the MSI, all is good.

If I point InstallShield at Version 2's folder, build, and test the MSI, it gets just beyond the IIS portion and then goes in to Rollback Mode.

Version 2 files the same, though a few of the files' contents have changed (some different .cs contents and a few .DLLs have changed), but I wouldnt think that would cause a rollback.

I even tried the old .DLLs just to make sure that wasn't the issue.

Here is the installation log: http://cpnd.us/ratboy/ROLLBACK.txt

Any help would be appreciated.
Labels (1)
0 Kudos
2 Replies
Highlighted
rrinblue22
Pilgrim

Re: Can anyone tell me why this installer is "Rolling Back" right after doing the IIS?

Excerpts from the log here:

[HTML]InstallShield 12:36:35: GetAdminSection for section 'system.webServer/handlers' and path 'MACHINE/WEBROOT/APPHOST/WebApplications/SISApps_GEO' and commitpath 'MACHINE/WEBROOT/APPHOST/WebApplications/SISApps_GEO'.
InstallShield 12:36:35: PutPropertyValue: sProperty accessPolicy sValue Script, Read bIsPath 0
InstallShield 12:36:35: PutPropertyCommon: sProperty accessPolicy sValue Script, Read bIsPath 0
InstallShield 12:36:35: Setting property 'accessPolicy' to value 'Script, Read' for element 'system.webServer/handlers'. Old value: '513'. m_sSectionName : 'system.webServer/handlers'.
InstallShield 12:36:35: put_value succeeded. get_StringValue now returns '0' with string value 'Read, Script'.
InstallShield 12:36:35: CommitChanges for path 'MACHINE/WEBROOT/APPHOST/WebApplications/SISApps_GEO' and physical path 'D:\WebApplications\SISApps_GEO\'.
InstallShield 12:36:35: CommitChanges failed with the following HRESULT: '-2147024891'. [/HTML]


HRESULT: '-2147024891

This translates to "Access is denied"

I guess there should be a config file probably read-only ... or may be not enough permissions to write/update.
0 Kudos
RatBoyGL
Pilgrim

Re: Can anyone tell me why this installer is "Rolling Back" right after doing the IIS?

Thanks!

My team mate found the web.config to be checked as read only. Woops!
0 Kudos