Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

COM Registration error

I have a .Net dll which I want to install into GAC and register for COM
(i.e. regasm xxx.dll)

I have added the dll to target folder and to GAC. I have checked "COM Interop" in the properties.

When building I get an error "-6017: The build was unable to extract COM information; make sure that you are running as Administrator"

Why do I need to run as administrator to build the installation project?

One strange thing is that the log says:
>Extracting COM data from 2 component(s)

Maybe the problem is that it is trying to extract COM information from both the dll in the target folder and in GAC. I have tried to set the Registration Type to "none" but it always reverts back to "Extract COM information"
0 Kudos
(2) Replies
Level 10


Kindly refer the topic Launching InstallShield with vs. Without Administrative Privileges in the InstallShield Limited Edition help document.

0 Kudos
Level 2

Never mind.

I solved it by adding a post-build step creating a tlb file with tlbexp.

Then I just added the tlb file to the deploy project and marked it for COM interop.

Another strange thing is that if I add "project output" to the deploy project I can't turn of "Extract COM information" (It is possible in the dialog but it does not stick). I just added the output dll directly and everything works fine.
0 Kudos