sandersonpj
Flexera beginner

Build warning -6487

When I build my new project (Basic MSI) I get this warning:

ISDEV : warning -6487: If you intend to distribute this upgrade as a patch, you should author the 'Patch Optimization' setting on the Advanced Settings panel of the Release Wizard.

I know there have been a number of threads on this subject before but none of them gives an adequate answer for my situation. I have absolutely no desire to issue the installer as a patch, so why do I need to be warned every time? How can I shut it up?

Following a lead, I created a minimal project from scratch - one feature, one component, single exe release. If I add dynamic files to the component, I get the warning. If I add a fixed file, the warning goes away. That's not really a solution as I don't want to have to keep an eye on all ~100 files in the real component.

It's not the whole story either. I have a (Basic MSI) project with dynamic files that doesn't produce the warning. It was originally created with IS12, converted to IS2008 and now converted to IS2009. I can't see any obvious difference between the release configuration in that project and in my warning-generating one, but there must be something!

Normally we compile things with treat-warnings-as-errors. It's annoying and disappointing to have to switch this off now.

If anyone has any tips, please let me know.
Thanks
Labels (1)
0 Kudos
4 Replies
MichaelU
Flexera
Flexera

KB Article Q113176 describes how to disable selected warnings. I believe this takes effect before warning-as-error.
0 Kudos

the answer link is dead - how to disable warnings

0 Kudos

0 Kudos
sandersonpj
Flexera beginner

Thanks, that worked a treat! It also works with the "-w" flag.
0 Kudos