Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

BSOD while extracting COM data

Hello Flexera Community.

I have an InstallShield "InstallScript MSI project", that uses COM data for registering .ocx files.
When the build gets to the .ocx files, the log says "Extracting COM data for 3 components".
Then it throws a blue screen of death (BSOD).

I was previously using InstallShield 2012 under 32bit Windows XP - no problem.
I then moved to 64bit Windows 10, IS2012 - BSOD.
I looked on the internet and found the problem listed. Some solution said to install IS2015 and use a newer version of some DLL it provides - in IS2012.
I just downloaded an evaluation copy of IS2016 (when I asked for evaluation copy, this is what it gave me), and hoped that the problem would be fixed.
But it is not fixed. I still get the BSOD.

I have other InstallShield "Basic MSI project"s that do not have any self registering files, no .ocx's, etc.
They build just fine under 64bit Windows 10, using IS2012 or IS2016.

Can someone help me ?
Thank you.

Asher Meth
Excalibur Systems
Labels (1)
0 Kudos
(2) Replies
Level 3

I received the following email response from Flexera support.
Thank you for your support request regarding the BSOD that you are seeing when extracting COM.

We are aware of this issue which is a result of Kernel registry filtering changes within Windows 10.
The resolution is to make sure that you have removed all version of Installshield older than 2015 from your windows 10 machine.

This is covered in the following knowledge base article:

In summary please remove Installshield 2012 from your Windows 10 enviroment and then try building your installer with IS2016 once again.

Please let me know if this resolves the problem - or if you require any further assistance don't hesitate to contact me.

Kindest regards,


I followed the link, and applied the suggested WorkAround:" The workaround involves removing every version of InstallShield other than InstallShield 2015 on the Windows 10 machine. It may also be possible to workaround this issue by copying the ISRegFlt.sys (ISRegFlt64.sys on 64 bit machines) from the InstallShield 2015 System folder to any other InstallShield's System folder on the machine."

It worked ! I am now able to run both IS2012 and IS2016 on my 64bit Windows 10.
Thank you for the prompt and on-the-nose response !

Asher Meth
Excalibur Systems
Level 8

Thank you for sharing this info !


0 Kudos