Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 2

Adding Java arguments to .jvm files


There are a few platforms where a 32-bit JVM is launched by default when you run a .sh installer. I want to launch a 64-bit JVM. On HP-UX for example, when I run the "java" command I would use the "-d64" switch on the command line to run it in 64-bit mode. How do I specify Java arguments such as the "-d64" switch inside a .jvm file? There doesn't seem to be any documentation on this.


El Pibe
Labels (1)
0 Kudos
(2) Replies
Level 9

If you are going to bundle a JVM you need two seperate launchers, one for Itanium and one for the 32 bit platform.

I'm not sure how you are creating your releases - are you using one Build Category or one for each platform? If you notice in the Distributions there are 3 different Lunchers for HP. If you want to use one launcher for HP and not use a bundled JVM then I guess you could just select the HPIA64 and select all the searches for JVM - there are 32 bit search routines under the ia64:

jvms/hpux_ia64 %

0 Kudos
Level 2

Perhaps I did not explain the problem clearly. I am not bundling the JVM. I want to launch a 64-bit JVM on HP-UX. I am using the .jvm files to search for a pre-installed JVM. The problem I have is that on platforms like HP-UX and Solaris, when the installer finds a JVM, the default behaviour is to always invoke it in 32-bit mode. This is true even if you use the "hp_hpux_15x_64bit.jvm" file. This is the same when launching Java on the command line - you have to use the "-d64" switch to launch Java with the 64-bit libraries.

The default "hp_hpux_14x_64bit.jvm" file contains the line "REQ_JAVA_ARGS:-d64" and I would have thought this is what I needed, however it doesn't seem to do anything. On Solaris I have worked around the problem using "JVM_EXE: bin/sparcv9/java" inside the .jvm file but doing the equivalent on HP-UX brings up a missing library error.
0 Kudos