Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

ANT build script for 11.5 MP

Hi All,

Does anybody have an up-to-date ANT build script that works with 11.5 MP?
The one posted at seems seriously out of date.

At the very least it would be nice to have an updated list of the minimum required classpath folders and jars needed to do a command line build with 11.5 MP. The example provided in the docs, ...\HelpLibrary\output\launch.txt, also seems out of date.

Labels (1)
0 Kudos
(8) Replies
Flexera Alumni

Here's a somewhat-updated version of the script from that newsletter article that seems to work:

location="C:\Program Files\Macrovision\IS11.5MP" />

location="C:\InstallShield MultiPlatform 11.5 Projects\projectName.uip" />

location="${ISMP}/distributables/platform/ext/windowsppk.jar" />

location="${ISMP}/distributables/platform/ext/linuxppk.jar" />

location="${ISMP}/distributables/platform/ext/solarisppk.jar" />

location="${ISMP}/distributables/platform/ext/aixppk.jar" />

location="${ISMP}/distributables/platform/ext/as400ppk.jar" />

location="${ISMP}/distributables/platform/ext/hpuxppk.jar" />

location="${ISMP}/distributables/platform/ext/macosxppk.jar" />

location="${ISMP}/distributables/platform/ext/webppk.jar" />

location="${ISMP}/distributables/platform/ext/genericunixppk.jar" />

location="${ISMP}/distributables/library/hsqldb.jar" />

location="${ISMP}/distributables/engine/engine.jar" />

0 Kudos
Level 3

Thank you very much, works well for me.
0 Kudos
Level 4

This one may work, also. I like to build the java beans as part of the packaging process. If you try this, let me know if this works with IS 11.5 or not. Oh, and change the properties to match your config.

includes="**/*.java" destdir="${isui.home}/classes">

description="generate the distribution">



0 Kudos
Level 3

I used the ANT build script (using the classpath) to bring up the IDE. The IDE comes up fine. However, in the View List, when I click on Additional Tools, nothing appears. Then when I expand the list and click on the String Table, I am getting a NullPoinerException error. But if I click on something else and click back on the String Table, then the NullPointerException is gone and the correct info is displayed. This symptom is similar when I click on others for the first time. What am I missing???

Cannot display view because the following error occurred:

java.lang.NullPointerException at com.installshield.isje.wizard.views.StringTableView.getEditorComponent(Unknown Source) at
com.installshield.isje.project.ProjectView.setCurrentView(Unknown Source) at com.installshield.isje.project.ProjectView.viewChanged(Unknown Source) at
com.installshield.isje.project.ViewListView.valueChanged(Unknown Source) at javax.swing.JTree.fireValueChanged( at
javax.swing.JTree$TreeSelectionRedirector.valueChanged( at
javax.swing.tree.DefaultTreeSelectionModel.fireValueChanged( at
javax.swing.tree.DefaultTreeSelectionModel.notifyPathChange( at
javax.swing.tree.DefaultTreeSelectionModel.setSelectionPaths( at
javax.swing.tree.DefaultTreeSelectionModel.setSelectionPath( at javax.swing.JTree.setSelectionPath( at
javax.swing.plaf.basic.BasicTreeUI.selectPathForEvent( at
javax.swing.plaf.basic.BasicTreeUI$Handler.handleSelection( at
javax.swing.plaf.basic.BasicTreeUI$Handler.mousePressed( at
java.awt.AWTEventMulticaster.mousePressed( at java.awt.AWTEventMulticaster.mousePressed( at
java.awt.Component.processMouseEvent( at javax.swing.JComponent.processMouseEvent( at
java.awt.Component.processEvent( at java.awt.Container.processEvent( at
java.awt.Component.dispatchEventImpl( at java.awt.Container.dispatchEventImpl( at
java.awt.Component.dispatchEvent( at java.awt.LightweightDispatcher.retargetMouseEvent( at
java.awt.LightweightDispatcher.processMouseEvent( at java.awt.LightweightDispatcher.dispatchEvent( at
java.awt.Container.dispatchEventImpl( at java.awt.Window.dispatchEventImpl( at
java.awt.Component.dispatchEvent( at java.awt.EventQueue.dispatchEvent( at
java.awt.EventDispatchThread.pumpOneEventForHierarchy( at
java.awt.EventDispatchThread.pumpEventsForHierarchy( at
java.awt.EventDispatchThread.pumpEvents( at java.awt.EventDispatchThread.pumpEvents( at
0 Kudos
Level 3

I found the cause. I needed to include this into the classpath:

0 Kudos
Level 4

The ant script posted above is for running command line builds, not for launching the IDE. Try launching the IDE normally.


0 Kudos
Level 2

RobertDickau wrote:
Here's a somewhat-updated version of the script from that newsletter article that seems to work:

Hi Robert,

Thanks for the updated script! I used it to build a test installer that I put together with the Project Assistant, and the build was successful. However, when I run the installer the buttons are inactive. Clicking on 'Next' or 'Cancel' does nothing -- the buttons don't even really "depress" unless I hold down for a second or so. Seems like this might be related to Swing.. as if the actions were somehow not defined for the buttons (??). Any ideas on why this would be happening? This problem does not occur when I build with the IDE.

[2006.03.15], it turns out (and this could be painfully obvious to some) that the ant build will only work after first using the IDE to build the package. The subdirectory generated by the IDE-invoked build (which has the same name as the .uip file) is required in order to create a functional installer -- though it isn't directly referenced in the ant script and, if missing, it will not break the build.

I was assuming that I could use the IDE to generate a valid .uip file, then point my ant script to this file and build. Not so. The ant build will not generate this subdirectory structure or the class files within, even though it depends on these files to create the installer.

Thanks much,
0 Kudos
Level 3


I have tried the first ant target posted in this thread, and it works, except that I'm getting a ton of compiler errors that it cannot file the core install shield packages/classes. Here are the first two lines of the errors. (I have the engine.jar on the class path unmodified from the first post.

Any ideas why it ant task can't find the IS jar files? Below is my ant target in whole.

[java] MESSAGE: Preparing project for compile...
[java] MESSAGE: Started compile at Mar 20, 2006 5:49:39 PM
[java] MESSAGE: Compiling classes D:\buildroot\installer\automated\installer\InstallShield\VueInstaller\CustomCode\lib
[java] WARNING: Error in on line 4: package com.installshield.event.ui does not exist
[java] WARNING: import com.installshield.event.ui.*;
[java] WARNING: ^
[java] WARNING: Error in on line 5: package com.installshield.wizard.swing does not exist
[java] WARNING: import com.installshield.wizard.swing.*;
[java] WARNING: ^
[java] WARNING: Error in on line 6: package com.installshield.ui.controls does not exist
[java] WARNING: import com.installshield.ui.controls.*;
[java] WARNING: ^

Ant Target:

0 Kudos