tjacobsky
Level 3

64-bit files going to program files (x86) directory

I am new to install shield and I am having issues with a 64-bit installation. I created a new installation and did the following.

Changed the General – Summary Information Stream – Template Summary to x64.

All of the components in the project to say 64-bit component – yes.

It still puts the components in the program files (x86) directory instead of the program files directory.

What do I need to do to make the files go to the program files directory?

Thanks for your help.
Labels (1)
0 Kudos
2 Replies
SteveLovell
Level 5

Im new as well but I would try and change the installdir on the general information screen from [ProgramFilesFolder] to [ProgramFiles64Folder]

Hope this helps
0 Kudos
BrHartmann
Level 7

You can also fine-tune where files go on the "Files and Folders" screen.

If changing the default InstallDir solves all your problems, great. However, if you have some components that you need in other locations, such as the system32 folder or ProgramFiles\CommonFiles folder, you should be aware of the presence of both the 32-bit and 64-bit folder options in the Files and Folders screen (i.e., you can right-click and choose "Show Predefined folders, then choose between CommonFilesFolder and CommonFiles64Folder).
0 Kudos