cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
messerej
Pilgrim

-4340: Internal build error when compiling empty project

Hello,

I am evaluating your product for my development team and tried creating an installer for our asp.net application. After configuring everything I would get an error after building. After removing many things I just created another installer project and without changing anything did a build. Even with an empty project I am getting a "-4340: Internal build error" when I build the project. What would cause this error message.

Is there a way to turn on a verbose log for compilation to get a better idea of what is going wrong? This error message is not very helpful in its current form.

Thank you for your help.

Build output is below

------ Build started: Project: TestSetup, Configuration: SingleImage ------
Created release folders
AdminExecuteSequence table successfully built
AdminUISequence table successfully built
AdvtExecuteSequence table successfully built
AdvtUISequence table successfully built
InstallExecuteSequence table successfully built
InstallUISequence table successfully built
Directory table successfully built
Feature table successfully built
FeatureComponents table successfully built
Component table successfully built
Loading File table
Building File table
File table successfully built
Class table successfully built
Extension table successfully built
ActionText table successfully built
AppSearch table successfully built
CCPSearch table successfully built
Condition table successfully built
AppId table successfully built
Started signing 962D.tmp ...
Property table successfully built
Binary table successfully built
CompLocator table successfully built
ControlCondition table successfully built
ControlEvent table successfully built
CreateFolder table successfully built
CustomAction table successfully built
Error table successfully built
DrLocator table successfully built
DuplicateFile table successfully built
Environment table successfully built
EventMapping table successfully built
Font table successfully built
ProgId table successfully built
ISIISItem table successfully built
ISIISProperty table successfully built
ISSelfReg table successfully built
IniFile table successfully built
IniLocator table successfully built
LaunchCondition table successfully built
MIME table successfully built
MoveFile table successfully built
MsiAssembly table successfully built
MsiAssemblyName table successfully built
MsiDigitalCertificate table successfully built
MsiDigitalSignature table successfully built
MsiPackageCertificate table successfully built
MsiPatchCertificate table successfully built
MsiShortcutProperty table successfully built
PatchPackage table successfully built
PublishComponent table successfully built
RegLocator table successfully built
Registry table successfully built
RemoveFile table successfully built
RemoveIniFile table successfully built
RemoveRegistry table successfully built
ReserveCost table successfully built
SelfReg table successfully built
ServiceControl table successfully built
ServiceInstall table successfully built
Shortcut table successfully built
Signature table successfully built
TextStyle table successfully built
TypeLib table successfully built
UIText table successfully built
Upgrade table successfully built
Verb table successfully built
_Validation table successfully built
ISEXP : error : -4340: Internal build error
Express\SingleImage - 1 error(s), 0 warning(s)
Log file has been created:

========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
Labels (1)
0 Kudos
1 Reply
messerej
Pilgrim

Re: -4340: Internal build error when compiling empty project

Could someone from Flexera please let me know if this is being researched? It is hard to evaluate a product when an empty project will not even build. It has been 13 days. If I could at least get a general cause for this specific error number I may at least get pointed in the right direction. This is not vague behavior but an actual error that I was hoping would be relatively quick to get a response for. At the very least could someone point me in the direction of turning on verbose logging?

Thank you for your assistance.
0 Kudos