cancel
Showing results for 
Search instead for 
Did you mean: 

Supported Java Virtual Machines for each Version of InstallAnywhere

Supported Java Virtual Machines for each Version of InstallAnywhere

Summary

This article shows the supported Java virtual machines for different versions of InstallAnywhere

Synopsis

The following is a listing of Java virtual machines that are supported by InstallAnywhere organized by each version.
Note: InstallAnywhere-generated installers are not supported on beta versions or on early-access releases of Java.

Discussion

InstallAnywhere 2018 SP1
ManufacturerSupported JVM Versions
Sun1.7.x, 1.8.x, 9
IBM1.7.x, 1.8.x, 9
HP1.7.x, 1.8.x, 9
Oracle1.7.x, 1.8.x, 9, 10, 11
OpenJDK1.7.x, 1.8.x, 9, 11

InstallAnywhere 2018
ManufacturerSupported JVM Versions
IBM1.7.x, 1.8.x, 9
HP1.7.x, 1.8.x, 9
Oracle1.7.x, 1.8.x, 9, 10
OpenJDK1.7.x, 1.8.x, 9

InstallAnywhere 2017
ManufacturerSupported JVM Versions
Sun1.6.x, 1.7.x
IBM1.6.x, 1.7.x, 1.8.x
HP1.6.x, 1.7.x
Oracle1.7.x, 1.8.x

InstallAnywhere 2015
ManufacturerSupported JVM Versions
Sun1.6.x, 1.7.x
IBM1.6.x, 1.7.x, 1.8.x
HP1.6.x, 1.7.x
Oracle1.7.x, 1.8.x

InstallAnywhere 2014
ManufacturerSupported JVM Versions
Sun1.6.x, 1.7.x
IBM1.6.x, 1.7.x
HP1.6.x
Oracle1.7.x, 1.8.x
Note: InstallAnywhere 2014 now supports Oracle Java 8 on Apple OS X Mountain Lion (10.8) and OS X Mavericks (10.9)

InstallAnywhere 2013
ManufacturerSupported JVM Versions
Sun1.5.x, 1.6.x, 1.7.x
IBM1.5.x, 1.6.x, 1.7.x
Apple1.5.x, 1.6.x
HP1.5.x, 1.6.x
Oracle1.7.x
Note: Installers built with InstallAnywhere 2013 support running with Java 8 on all platforms except Mac OS X. InstallAnywhere 2013 also has support for building OS X?based installers that use Java 7 at run time, and has support for creating VM packs with Oracle JRE 7, as well as for bundling installers with Oracle JRE 7.

InstallAnywhere 2012
ManufacturerSupported JVM Versions
Sun1.5.x, 1.6.x, 1.7.x
IBM1.5.x, 1.6.x, 1.7.x
Apple1.5.x, 1.6.x
HP1.5.x, 1.6.x
Oracle1.7.x

InstallAnywhere 2011
ManufacturerSupported JVM Versions
Sun1.4.x, 1.5.x, 1.6.x
IBM1.4.x, 1.5.x, 1.6.x, 1.7.x
Apple1.4.x, 1.5.x, 1.6.x
HP1.4.x, 1.5.x, 1.6.x
Oracle1.7.x
Was this article helpful? Yes No
No ratings