This website uses cookies. By clicking Accept, you consent to the use of cookies. Click Here to learn more about how we use cookies.
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
- Revenera Community
- :
- InstallAnywhere
- :
- InstallAnywhere Knowledge Base
- :
- Digital Signing Patch for InstallAnywhere 2015 and above
Subscribe
- Mark as New
- Mark as Read
- Subscribe
- Printer Friendly Page
- Report Inappropriate Content
Digital Signing Patch for InstallAnywhere 2015 and above
Digital Signing Patch for InstallAnywhere 2015 and above
Symptoms:
InstallAnywhere digital signing feature uses a timestamp URL from Symantec which is being decommissioned (more details here) and migrated to Digicert. Signing with new Digicert URL causes a breakage in Digital Signing
Diagnosis:
When signing an installer with SHA-256 digest, using the new Digicert server (http://timestamp.digicert.com), the resulting installer is signed by SHA-256 digest, but the counter signatures are signed with SHA1 due to an incorrect order in which InstallAnywhere calls the signing APIs
Affected InstallAnywhere Versions
InstallAnywhere 2015
InstallAnywhere 2017
InstallAnywhere 2018
InstallAnywhere 2020
All minor releases of the above releases included
Resolution
- The issue is resolved in a hotfix that can be downloaded from here. Please note that the hotfix is applicable on the latest service packs of above affected versions.
- Download and extract the contents of the file.
- Copy x86/IAWinDigiSign.exe to <IA_Install_Location>/resource/nativetools/windows
- Copy x64/IAWinDigiSign.exe to <IA_Install_Location>/resource/nativetools/windows64
- After replacing the above files, in your InstallAnywhere project, navigate to Project à Platforms à Windows à Digital Signing and update the Timestamp server field to http://timestamp.digicert.com
Additional Information
If there are any additional issues, please contact our Technical Support team
No ratings