Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 5

uninstall failure

sorry, im posting this in wrong place but needed help urgently

I am using IA2010 SP1 and created my package , while uninstalling my product from add remove programs I am getting an error as described below, how to resolve this issue?? it is urgent.. please help me..

Fatal application error as title of the error message box

the application has unexpectedly quit with warning and content of the message as shown below

invocation of this java aplication has caused an invocation TargetException. This application will now exit.(LAX)

i clicked on details button below exception is showing,

java.lang.IllegalArgumentException: No product for ID=
at ZeroGgv.(DashoA10*..)
at ZeroGf3.c(DashoA10*..)
at ZeroGf3.e(DashoA10*..)
at ZeroGf2.(DashoA10*..)
at com.zerog.ia.installer.Installer.setMetadata(DashoA10*..)
at com.zerog.ia.installer.InstallerMetaData.setInstaller(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.m(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.k(DashoA10*..)
at com.zerog.ia.installer.LifeCycleManager.a(DashoA10*..)
at com.zerog.ia.installer.Main.main(DashoA10*..)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.zerog.lax.LAX.launch(DashoA10*..)
at com.zerog.lax.LAX.main(DashoA10*..)
Labels (1)
0 Kudos
(4) Replies
Level 9

I guess you have not generated the Product ID. Go to Project/Description and click Generate ProductID, then rebuild.

0 Kudos
Level 5

hi Jerome thanks for quick reply,

in my previous post I replaced my product id with "my product ID". actual product id is there in my project file.

when i tried to remove product from add remove programs it is popping an error message , so i opened zerog registry file and found that only few lines are there as shown below, my guess IA uninstaller is looking for some id in zerog registry file am i right?

none of the file are removed but zerog registry file is modified. what could be the reason to leave the host in this state .I am unable trace root cause can you please help me...


0 Kudos
Level 9

I guess you are right, it is searching for ID in IA registry.

I am not using IA registry files due to similar issues I encountered in the past ... I'll suggest you to do the same.

So I"m afraid I cannot help you... Maybe try to totally delete the IA registry file and try uninstalling again.

0 Kudos
Level 7


Have you tried removing only specific features after installation? Is there anything that you did after installation to alter the product installation.

The warning that you've posted is seen when the product is not installed properly because of which the entry in registry is not made or all the features of the product has been removed which is equivalent to uninstalling the product.
0 Kudos