rajalakshmi
Level 3

create the installanywhere using jdk1.6.0_20 version

Hi,

I require to create the installanywhere using jdk1.6.0_20 version.
Can u please tell me the procedures to create installanywhere using jre1.6.0_20(jdk1.6.0_20)?

Note:

I tried to create instllanywhere using jdk1.6.0_20. I am not able to install the exe file(It is not getting installed properly). The following error messages came when i run the build command.

[exec] /vobs/cacp/java/packaging/target/iaclient/Web_Installers/InstData/Windows/VM/installCACPClient.exe
[exec] Building merge module...
[exec] 'SWING' UI not supported by VM.
[exec] java.lang.NoClassDefFoundError
[exec] at ZeroGh.b(DashoA10*..)
[exec] at ZeroGh.a(DashoA10*..)
[exec] at com.zerog.ia.installer.Installer.(DashoA10*..)
[exec] at com.zerog.ia.installer.Installer.(DashoA10*..)

Thanks
Labels (1)
0 Kudos
9 Replies
shemareddy
Level 4

Hello ,

Which version of IA have you been trying to use and on what platform.?
How exactly are you trying to build installer with the required version?
0 Kudos
ivenkata
Level 6

Did you try creating the installer by creating the VMPack of jre 1.6.0_20? Please Provide us more steps in detail to help you.
0 Kudos
rajalakshmi
Level 3

I am new to this forum and so created multiple threads for my query. I apologize for the same.

I am trying to create an installer using IA version 10 with JRE 1.6.0_20
on Unix platform. There is a build script which uses MAVEN internally to compile the JAVA code and create the required JARS. The script next utilizes IA XML file to create the installer with required JARS packaged.

I have a requirement to support JRE1.6.0_20 on Unix platform for which I already have the VM pack available.

We are able to successfully create installer using JRE1.6.0_17 and also able to install it on a Windows machine.

The problem is that I am not able to even create installer with JRE1.6.0_18 and onwards. With these JRE versions I get the error which I stated earlier.

Is IA version 10 compatible with JRE1.6.0_20? Please let me know which version of IA can be used with JRE1.6.0_20 as I do not have any problem
using lower/higher version of IA.

Any help will be highly appreciated. Plz let me know if you require any other information.
0 Kudos
pv7721
Level 20

Ok, this is understandable. But now you've mentioned JRE and not JDK, which was your original message. So what is after all, JDK or JRE?
0 Kudos
rajalakshmi
Level 3

I am using jre 6 with jdk1.6.0_20
0 Kudos
pv7721
Level 20

Ok, still confused, let me try to rephrase this: when you will want to install your application, is bundling the JRE enough for it to run, or does it need the JDK?
0 Kudos
rajalakshmi
Level 3

Hi Vlad,
We need JRE only while installing our application.
0 Kudos
rajalakshmi
Level 3

Hi Venkata/Sudeep,
I am using IA version 10 and trying to build on solaris platform. We have created VM packs using JRE1.6.0_20.
0 Kudos
pv7721
Level 20

So the VM packs for the JRE 1.6.0_20 you created yourself? Have you followed the procedure available here: http://kb.flexerasoftware.com/selfservice/viewContent.do?externalID=Q000195
Did you know for instance that there were 1.6.0_20 VM packs provided by IA, available for download from here: http://www.flexerasoftware.com/products/installanywhere/files-utilities.htm (click on VM Packs)
These have been tested and known to be working! Maybe you could give them a try?
0 Kudos